CRM – Integração – Erro na requisição Web Service: A requisição Web Service foi executada: Ocorreram Erros. A requisição Web Service foi executada: Ocorreram erros no processamento, verifique os detalhes A requisição Web Service foi executada: Não foi
Incidente
No módulo Contas, ao tentar enviar a Conta para o ERP, é apresentada a mensagem: Erro na requisição Web Service: A requisição Web Service foi executada: Ocorreram Erros. A requisição Web Service foi executada: Ocorreram erros no processamento, verifique os detalhes A requisição Web Service foi executada: Não foi possível processar as definições do cliente na empresa XX, filial XX. Erro: Não foi possível executar as validações dos campos. Definições do histórico do representante XX para a empresa XX não cadastradas.
Causa
Essa mensagem é apresentada, pois o representante vinculado a essa conta, não está cadastrado no ERP com o ID informado para a empresa e filial informados na mensagem.
Solução
Para que a mensagem não seja apresentada ao efetuar o envio da Conta para o ERP, realize os passos a seguir:
1. Acesse a Plataforma;
2. Entre em Gestão de Relacionamento | CRM / Contas / Consultar Contas;
2.1. Localize a conta que está apresentando a mensagem;
2.2. Abra a aba Definições;
2.3. Confirme no campo Representante, qual o representante atrelado a conta;
2.4. Acesse Gestão de Relacionamento | CRM / Sistema / Gerenciar Usuários CRM;
2.5. Localize o usuário/representante ligado a conta, verificado no passo 2.3;
2.6. Confirme o ID ERP Representante do usuário em Identificadores do Usuário;
3. Acesse Gestão Empresarial | ERP;
3.1. Entre na tela e navegue até a tela F090REP - Cadastros / Representantes / Cadastro (Cadastro de Representantes);
3.2. Verifique a ID do representante correto para a empresa e filial em questão;
4. Caso seja diferente do informado no cadastro do usuário, entre em Gestão de Relacionamento | CRM / Sistema / Gerenciar Usuários CRM;
4.1. Localize o usuário/representante;
4.2. Atualize o ID ERP Representante do usuário em Identificadores do Usuário;
5. Reenvie a integração no CRM.
Atenção! Antes de realizar qualquer alteração, analise o impacto que poderá ter em outros lançamentos/processos do sistema.