IT Services - Integrador HCM - Integrador HCM apresenta erro e mesmo reiniciando não fica no ar (Ambiente Cloud Senior)
Incidente
Em alguns momentos, mesmo realizando o restart do serviço do Integrador HCM o mesmo não fica estável e em execução. Esta documentação possui informações necessárias para que o problema possa ser verificado de forma mais ágil e assertiva pelo time de Suporte Cloud Senior.
Causa
Este problema geralmente ocorre devido a credenciais do usuário hcm_integrador e das chaves de aplicação que estão cadastradas no SeniorConfigCenter.
Como acaba ocorrendo uma inconsistência no serviço, o acesso ao Dashboard do Integrador HCM também é impactado, onde ao realizar o acesso ao mesmo ocorrem alertas de erro de falha de comunicação do mesmo com os webservices.
Para resolução do caso junto ao suporte Cloud Senior, execute os passos abaixo:
Solução
A solução abaixo se aplica aos seguintes ambientes na Cloud Senior:
- Antares;
- Sirius;
- Vega;
- Bellatrix
- Aludra
1. Realize o restart do Serviço do Integrador HCM através da ferramenta Gestão Cloud para revalidação do serviço;
2. Execute a redefinição da senha do usuário hcm_integrador através do SGU;
3. Verifique para que o usuário hcm_integrador esteja definido como usuário master. Para mais informações sobre vínculo de usuários a grupos acesse o KCS Como realizar o vínculo de um usuário a um grupo no SGU.
4. Realize a Redefinição das Chaves de Aplicação;
5. Acesse a Ferramenta Gestão Cloud;
6. Acesse o menu Gestão de Configurações / Configurações ;
7. Clique para editar os valores referentes a sessão vetorh / hcm;
8. Preencha os valores referentes a accesskey, secretkey e User e Password;
9. Reinicie os serviços de middleware e wildfly e serviço do Integrador HCM conforme artigo Como realizar o restart dos serviços de middleware e domínio web para clientes em ambiente Cloud Senior;
10. Valide novamente o acesso ao Dashboard do Integrador HCM;
Importante
- Este artigo refere-se diretamente a serviços do Integrador HCM que estão instalados em ambientes na Cloud Senior
- Informações referentes a credenciais de acesso e chave secret devem ser encaminhadas utilizando o Processo via OneTimeSecret.
- Caso necessário realizar uma validação na autenticação via chaves de aplicação, execute os Teste de Autenticação via Postman.