IT Services - Autenticação Serviços - Não foi possível efetuar o login no tenant xxxx com o accessKey e o secret informados em serviços no ambiente Cloud Senior
Incidente
Ao verificar os logs de Processos Automáticos que utilizam as chaves de aplicação da Platforma Senior X para autenticação é possível verificar nos logs o seguinte retorno:
Erro na execução do processo automático: Falha da comunicação: Erro na criação do comunicador Rest: Erro ao conectar: {"message":"Não foi possível efetuar o login no tenant xxxx com o accessKey e o secret informados.","errorCode":"400","reason":"BAD_REQUEST","domain":"platform","service":"authentication"}
Causa
Este problema pode ocorrer por 2 motivos principais: Ou os valores das chaves estão incorretos, ou não há vínculo desta com o papel Admin da Plataforma Senior X.
Solução
Para solução do problema, realize os passos abaixo:
1. Realize a geração de novas chaves de aplicação na Plataforma Senior X conforme o artigo Como realizar a redefinição das chaves de aplicação;
2. Realize a associação desta chave de aplicação com o papel Admin conforme o artigo Como Associar uma Aplicação a um Papel;
3. Acesse a ferramenta Gestão Cloud;
4. Acesse o menu Gestão de Configurações / Configurações ;
5. Clique para editar os valores referentes a sessão seniorxt;
6. Preencha os valores referentes a accesskey, secretkey e Tenant;
7. Reinicie os serviços de middleware e wildflky conforme artigo Como realizar o restart dos serviços de middleware e domínio web para clientes em ambiente Cloud Senior;
8. Valide novamente a execução do processo automático;