Ronda Senior X - Proxy SDK - O proxy SDK não fica operacional e não gera pasta de logs
Incidente
No processo de comunicação do Ronda Senior X, o proxy SDK não consegue ficar operacional, não gerando nem mesmo a pasta de Log, e consecutivamente os logs também não são gerados.
Causa
A situação ocorre quando no servidor onde o serviço foi instalado há mais de um JAVA JDK rodando. Por exemplo, no servidor que tem o Integrador do Ronda Senior X e Proxy SDK instalados, a situação pode ocorrer, pois os serviços utilizam versões diferente do Java.
Solução
Para solucionar esta situação realize os passos a seguir:
1. Acesse o servidor onde está instalado o serviço do Proxy SDK;
2. Abra a pasta do Proxy SDK. A pasta fica instalada por padrão no Disco Local, normalmente no: C:\;
3. Dentro da pasta do Proxy SDK, busque pelo arquivo Updater.properties e abra o mesmo em um editor de texto.
- Para abrir o arquivo com um editor de texto, clicar com o botão direito do mouse sobre o arquivo, em seguida clicar em: Abrir com e selecionar o editor. Exemplo de editores de texto: Bloco de notas, Notepad, Notepad++;
4. Adicionar a chave: updater.java_home_env=JAVA_HOME dentro do arquivo;
5. Salvar o arquivo;
6. Reiniciar o serviço do Proxy SDK pelo serviço do Windows (Services.msc);
7. Validar se o serviço do Proxy SDK está operacional e gerando Logs. Caso não, acionar o suporte do Ronda Senior X.