IT SERVICES - INFRAESTRUTURA - Queda do sistema após poucos minutos ocioso dentro do ambiente Cloud
Incidente
Após conectado no ambiente Cloud via modo de acesso HTML5, permanecendo ocioso ou a janela se encontrando em stand by por cerca de 10 minutos é apresentado a mensagem de desconexão do sistema "Esta conexão não é mais válida".
Causa
Quando o sistema é acessado via navegador (modo HTML5), a sessão depende diretamente da aba permanecer ativa no navegador.
Atualmente, navegadores modernos como o Google Chrome e o Microsoft Edge utilizam recursos de otimização de desempenho, como:
- Economia de memória
- Suspensão de abas em segundo plano
- Modo de eficiência / desempenho
Esses recursos pausam abas que ficam inativas por um período.
Importante
Esse comportamento não é um erro do sistema, mas sim uma funcionalidade do navegador para economizar recursos da máquina.
Solução
Configurar no navegador utilizado para manter a aba ativa mesmo quando permanecer ocioso.
1- Acesse as configurações do navegador utilizado (exemplo utilizado Chrome).
2- Acesse a aba "Desempenho".
3 - Selecione a opção "Manter estes sites ativos".
4- Clique em "Adicionar sites atuais" ou "Adicionar sites manualmente".
4.1- Insira a url de acesso utilizada de acordo com seu Ambiente;
5- Feche o navegador e reabra-o novamente para aplicar as configurações alteradas.