ERP MEGA - Office Banking - Contrato de Pagamento não Encontrado
Incidente
No módulo Financeiro, ao processar um arquivo de retorno bancário, é apresentada a mensagem: Contrato de pagamento eletrônico não encontrado!
Causa
Esta mensagem é apresentada por 3 principais motivos:
1. A data do banco de dados está incorreta;
ou
2. O código de identificação da empresa que consta no arquivo de retorno é diferente do que consta cadastrado no contrato do Office Banking;
ou
3. Não está configurado no formato de pagamento o Header de retorno;
ou
4. No contrato de pagamento da conta não está cadastrado o Número Inscrição;
O número da agência e conta corrente do arquivo de retorno, estão diferentes do número da conta e agência cadastrados no contrato de pagamento da conta conta financeira;
Solução
1. Verifique se a a data do banco de dados está incorreta:
1.1 No servidor, abra o PL/SQL com o owner mgglo e senha megaglo;
1.2 Acesse File / New / Sql Window;
1.3 Execute o comando:
select sysdate from dual
1.4 Solicite ao DBA a correção da data do banco de dados.
Observação: Orientamos que esse procedimento seja executado por um DBA ou pelo responsável da área de TI da empresa.
2. Verifique se o código de identificação da empresa que consta no arquivo de retorno é diferente do que consta cadastrado no contrato do Office Banking:
Para verificar se o código de identificação da empresa que se encontra no arquivo retorno é o mesmo definido no contrato do Office Banking, realize as seguintes verificações:
2.1 No módulo Financeiro, acesse o Office Banking e clique no botão Avançar;
2.2 Selecione a conta financeira clique no botão Avançar;
2.3 Em Operação, marque a opção Envio de Arquivo, em Modalidade de Office Banking marque a opção Cobrança bancaria e clique novamente em Avançar;
2.4 Selecione o contrato de cobrança e clique em Editar;
2.5 Na pasta Carteira, preencha ou anote a informação do campo Identificação Empresa;
Importante: Esta informação é composta pelo número da agencia, dois zeros e o número da conta corrente com o dígito. O banco Itaú é o único que utiliza a Identificação da Empresa com esta composição. Em caso de dúvida sobre o preenchimento da informação, entre em contato com o Banco.
2.6 Clique em OK para salvar;
2.7 Abra o arquivo retorno disponibilizado pelo banco com o bloco de notas do Windows;
2.8 No bloco de notas, acesse a opção Formatar e desmarque a opção Quebra Automática de Linha;
2.9 Ainda no bloco de notas, clique em Exibir e marque a opção Barra de Status;
2.10 Na linha 1, posição 27 a 39, verifique se a informação é a mesma anotada/preenchida no passo 2.5:
Obs: A posição indicada no rodapé do arquivo pode variar conforme a configuração do formato.
2.11 Processe novamente o arquivo retorno.
Atenção! Antes de realizar qualquer alteração, analise o impacto que poderá ter em outros lançamentos/processos do sistema.
3. Verifique a configuração de formato de pagamento a aba Header de retorno:
3.1 Acesse o módulo Financeiro/ Office Banking;
3.2 Selecione a conta financeira em questão / clique botão avançar;3.3 Selecione a opção Envio de Arquivo e Pagamento Eletrônico e clique no botão avançar;
3.4 Clique no Botão Editar e na aba formatos anote os formatos que estão vinculados ao contrato com o Banco;
3.5 Ainda no módulo Financeiro / Opções / Utilidades / Configuração Office Banking / Gerador de Formatos;
3.6 Edite o formato anotado no passo 4;
3.7 Na aba retorno verifique e se necessário configure as sub abas Header e Trailler conforme o layout disponibilizado pelo banco;
3.8. Clique em Ok para salvar.
Atenção! A imagem a seguir é só um exemplo, e não necessariamente exibe as configurações que atenderão à sua configuração.
Para preencher as informações corretas, consulte o layout disponibilizado pelo seu banco.