HCM – Integrador HCM – Usuários cadastros no SGU não estão sendo sincronizados e integrados para a plataforma Senior X
Incidente
Ao utilizar o Integrador HCM, usuários cadastrados no SGU não estão sendo sincronizados e integrados para a plataforma Senior X.
Causa
Este incidente pode ocorrer devido a uma série de contextos listados a seguir na seção de solução, onde dependendo de algumas configurações o Integrador HCM não conseguirá realizar a operação de sincronia e integração de usuários com a plataforma.
Solução
Para que esse incidente não ocorra, realize os passos a seguir:
1. Acesse o dashboard do Integrador HCM e na seção módulos ativos verifique quais módulos estão configurados para o tenant, em cenários onde não existe pelo menos o módulo Painel de Gestão ou Integrador SST e os colaboradores vinculados ao usuário em questão não possuírem indicação para nenhum destes módulos, realize os passos abaixo:
1.1. Abra o arquivo integration.properties, localizado na pasta raiz de instalação do Integrador HCM;
1.2. Configure o parâmetro 'useraccount.module.control.disabled' com valor true. Caso haja duvidas quanto a este parâmetro ou configuração, clique aqui para acessar a documentação do Integrador HCM;
1.3. Salve o arquivo integration.properties;
1.4. Reinicie o serviço do Integrador HCM;
1.5. Acesse o dashboard do Integrador HCM, na guia integração execute o fluxo 'Usuários do HCM';
1.6. Acesse a plataforma Senior X com um admin da mesma e verifique na tela de gestão de usuários em Tecnologia / Administração / Gestão dos Usuários se os mesmos foram integrados.
2. Verifique o Integrador registrado, onde quando utilizado o Integrador HCM é preciso que o mesmo esteja registrado na plataforma em cenários que o tenant inicialmente utilizava o Integrador ETL. Para mais informações referente a este processo verifique o artigo abaixo:
Após a implantação do integrador HCM não ocorre a sincronização de usuário devido ao registro prévio do integrador ETL.
3. Confirme se a autenticação do tenant realmente é G5, para isto realize os passos abaixo:
3.1. Acesse o dashboard do Integrador HCM;
3.2. No campo 'Tipo de Autenticação", verifique se o mesmo esta com o valor 'G5', caso não e deva realmente ser, entre em contato com a equipe de suporte do produto;
3.3. Efetue login na plataforma Senior X com um admin da mesma;
3.4. Acesse o menu Tecnologia / Administração / Gestão dos Tenants / Configurar;
3.5. Clique na guia autenticação e depois na guia autenticação G5;
3.6. Verifique se a autenticação G5 esta habilitada, caso não e deva realmente ser, habilite a mesma e clique em salvar. Em casos de duvidas quanto a esta configuração, entre em contato com a equipe de suporte e aplicativos;
3.7. Volte no dashboard do Integrador HCM e na guia integração execute o fluxo 'Usuários do HCM';
3.8. Acesse a plataforma Senior X com um admin da mesma e verifique na tela de gestão de usuários em Tecnologia / Administração / Gestão dos Usuários se os mesmos foram integrados.
4. Valide os logs de integração, para isto realize os passos a seguir:
4.1. Acesse o dashboard do Integrador HCM, na guia integração execute o fluxo 'Usuários do HCM';
4.2. Acesse a pasta log localizada dentro da pasta raiz de instalação do Integrador HCM;
4.3. Busque pelo log de integração com a data atual onde o mesmo terá o nome gerado como integration e a data atual invertida, por exemplo, em um log gerado no dia 05/06/2023 o arquivo terá como nome 'integration-20230605';
4.4. Abra o arquivo e verifique através da hora de execução inicial e final do fluxo de usuários do hcm um possível log com a indicação da causa da não integração;
4.5. Avalie o log e trate a divergência e em caso de duvidas entre em contato com o suporte do produto.
5. Valide os logs de sincronia, para isto realize os passos a seguir:
5.1. Efetue login no SGU, localizado dentro da pasta vetorh do sistema HCM XT;
5.2. Altere alguma informação de um usuário que não sincronizou, como por exemplo seu nome ou senha;
5.3. Acesse a pasta log localizada dentro da pasta raiz de instalação do Integrador HCM;
5.4. Busque pelo log de sincronia com a data atual onde o mesmo terá o nome gerado como sync e a data atual invertida, por exemplo, em um log gerado no dia 05/06/2023 o arquivo terá como nome 'sync-20230605';
5.5. Abra o arquivo e verifique através da hora que a alteração foi feita no SGU um possível log com a indicação da causa da não sincronia;
5.6. Avalie o log e trate a divergência e em caso de duvidas entre em contato com o suporte do produto.
Atenção! Antes de realizar qualquer alteração, analise o impacto que poderá ter em outros lançamentos/processos do sistema.