HCM – Integrador HCM – Não foi possível obter o token por meio da API Application Management devido as propriedades "com.senior.vetorh.hcm.g7.acess_key" e "com.senior.vetorh.hcm.g7.secret" não estarem corretamente preenchidas
Incidente
Nos logs do Integrador HCM, quando o mesmo tentar autenticar na plataforma Senior X, é apresentada a mensagem: Não foi possível obter o token por meio da API Application Management devido as propriedades "com.senior.vetorh.hcm.g7.acess_key" e "com.senior.vetorh.hcm.g7.secret" não estarem corretamente preenchidas.
Causa
Esta mensagem é retornada, pois o Integrador HCM tenta inicialmente autenticar na plataforma Senior X através da rotina de application management da mesma, utilizando os campos chave de acesso e secret, onde se na seção HCM do SeniorConfigCenter os campos de chave de acesso e chave secreta estejam vazios ou incorretos irá ocorrer este problema.
Solução
Para que a mensagem não seja apresentada quando o Integrador HCM tente efetuar a autenticação na plataforma Senior X, realize os passos a seguir:
1. Efetue login na plataforma Senior X com um usuário admin da mesma;
2. Acesse o menu Tecnologia / Administração / Gerenciamento de aplicações;
3. Clique no botão Nova aplicação, e inclua as informações conforme imagem abaixo:
4. Clique no botão salvar e copie a chave de acesse e também o secret. Neste ponto é importante se atentar pois o secret só ficará disponível neste momento, após abrir novamente essa aplicação o secret ficará oculto;
5. Clique em salvar;
6. Acesse o menu Tecnologia / Administração / Autorização / Gestão dos Papéis;
7. Procure pelo papel admin e clique em editar;
8. Clique na guia aplicações, localize a nova aplicação criada e associe a mesma;
9. Clique no botão salvar, localizado ao final da tela;
10. Execute o SeniorConfigCenter localizado na pasta raiz de instalação do sistema on-premise;
11. Acesse o menu Sistemas / Gestão de Pessoas / HCM;
12. Preencha os campos chave de acesso e chave secreta, sendo estes os campos chave de acesso e secret respectivamente. Para maiores informações Acesse aqui a documentação completa do HCM;
13. Clique no botão aplicar;
14. Reinicie os serviços de middleware e Integrador HCM através do recurso de serviços, do qual irá depender do sistema operacional utilizado.
Atenção! Antes de realizar qualquer alteração, analise o impacto que poderá ter em outros lançamentos/processos do sistema.