HCM – Atualização de Históricos – Travamento ou lentidão na atualização de históricos
Incidente
Nos módulos do HCM, ao tentar abrir um módulo é aberta uma janela de Atualização de Históricos junto com o módulo, esta mensagem fica processando por muito tempo, e em alguns momentos não sai da tela e não deixa o sistema abrir.
Causa
Este incidente ocorre pois a rotina de atualização de históricos está com alguma dificuldade de execução, devido a alguma sobreposição indevida ou problema no banco de dados.
A atualização de históricos ocorre sempre para o primeiro usuário que logar no sistema somente na primeira vez no dia.
Solução
Para que este incidente não ocorra, realize os passos a seguir:
1. Atualize o campo Data da Última Atualização de históricos no banco de dados via update, para que a rotina não seja executada ao abrir o sistema neste dia, deve ser feito um update para a data atual;
1.1. Até a versão 6.2.35 esta informação fica na R250TAB.DatAhc, na versão 6.10.1 fica na R250ALT.DatHor com CodAlt=28.
Atenção
Este update deve ser feito por um DBA ou usuário com conhecimento avançado em banco de dados, pois o comando pode mudar conforme tipo de banco.
Após este update no banco de dados o sistema já deve abrir diretamente durante este dia sem realizar o processo de atualização de históricos.
Para analisar o motivo que estava causando o travamento lentidão, analise o Log de Processamentos.
Para acessar o log de processamentos, realize os passos a seguir:
1. Acesse o menu Diversos / Logs / Processamentos;
1.1. Preencha a data e hora inicial e final;
1.2 No campo Tipo de processamento informe 64 - Atualização de Históricos;
1.3 Clique em Mostrar.
2. Trate os casos que apontarem problemas no log.
Importante
Não é possível mapear quais incidentes podem ocorrer neste log, é necessário analisar e tratar pontualmente.
Atenção! Antes de realizar qualquer alteração, analise o impacto que poderá ter em outros lançamentos/processos do sistema.