HCM – S-2190 – Não é possível excluir este registro, pois já foi realizado o fechamento de admissão do colaborador
Incidente
No módulo Administração de Pessoal, ao tentar excluir um Registro Preliminar, é apresentada a mensagem: Não é possível excluir este registro, pois já foi realizado o fechamento de admissão do colaborador.
Causa
Este incidente ocorre pois o Registro Preliminar já foi vinculado a uma Ficha Cadastral, e o leiaute S-2200 desta Ficha Cadastral está na tela de Gerar Não Periódicos para geração.
Solução
Importante: Caso o leiaute S-2200 já tenha sido enviado ao eSocial, verifique o artigo: HCM – S-2190 – Não é possível excluir este registro, pois já foi realizado o fechamento de admissão do colaborador
Para que a mensagem não seja apresentada ao efetuar a exclusão do Registro Preliminar, realize os passos a seguir:
1. Acesse o módulo Administração de Pessoal, clique em eSocial / Colaboradores / Registro Preliminar por Trabalhador / Cadastro;
1.1. Localize o Registro Preliminar que deve ser excluído, e valide o código do colaborador que está vinculado à este registro, no campo Colaborador;
2. Acesse Colaboradores / Históricos / Categoria eSocial;
2.1. Localize o colaborador que foi vinculado ao Registro Preliminar;
2.2. Na data de admissão, altere a Categoria eSocial para 9999 - Não se Aplica;
3. Acesse eSocial / Gerar Não Periódicos, valide se o leiaute S-2200 não consta mais na tela;
4. Acesse eSocial / Colaboradores / Registro Preliminar por Trabalhador / Cadastro, e exclua o Registro Preliminar;
5. Acesse Colaboradores / Históricos / Categoria eSocial, e ajuste a Categoria eSocial para a correta novamente;
6. Acesse eSocial / Colaboradores / Fechamento da Admissão, e processe o leiaute S-2200;
7. Acesse eSocial / Gerar Não Periódicos, e processe o leiaute S-2200;
8. Acesse eSocial / Consulta Pendências, caso o leiaute S-2200 esteja para envio manual envie o leiaute.
Atenção! Antes de realizar qualquer alteração, analise o impacto que poderá ter em outros lançamentos/processos do sistema.