HCM – Abertura do Sistema – Problemas na inicialização: sun.jdbc.odbc.JdbcOdbcDriver
Incidente
Ao abrir o sistema HCM é apresentado a mensagem:
Classe da exceção: BaseException.
StackTrace: br.com.senior.asas.sysutils.BaseException: Problemas na inicialização: sun.jdbc.odbc.JdbcOdbcDriver
Causa
Este incidente ocorre, pois houve alteração nos arquivos da pasta Java, dentro da raiz da instalação, causando incompatibilidade pois foi corrompido.
Solução
Para que o incidente seja corrigido e não apresente mais a mensagem ao abrir o sistema, realize os passos a seguir:
1. Execute o comando java.exe -version via prompt por linha de comando para validar a versão da JDK utilizada no ambiente;
2. Valide a versão da JDK utilizada no sistema HCM, chegue até a pasta Java na raiz da instalação da aplicação via prompt e execute o seguinte comando:
java.exe -version;
3. Valide se ambas as versões correspondem as nossas plataformas homologadas para a versão do sistema com base na documentação, no seguinte link:
3.1. Todas as informações sobre as versões 6.10.1.xx encontram-se detalhadas na documentação - Plataformas homologadas para a Versão 6.10.1.xx.
3.2. Todas as informações sobre as versões 6.2.35.xx encontram-se detalhadas na documentação - Plataformas homologadas para a Versão 6.2.35.xx.
4. Faça um backup da pasta Java na raiz da instalação da Senior após validado as informações quanto a versão correta a ser utilizado.
5. Efetue a troca da pasta Java na raiz da instalação pela pasta Java que contém na mídia utilizada para a atualização.
Observação: Utilize a mídia de instalação na mesma versão do sistema.
6. Reinicie os Serviços, Senior Middleware e Senior - Serviço de Informações.