HCM - S-1200 - Null
No módulo Administração de Pessoal, ao gerar os eventos periódicos da declaração mensal do eSocial, é apresentada a mensagem: Null.
Causa
Esta mensagem é apresentada, pois o colaborador que está sendo processado o leiaute, já teve outro vínculo dentro do sistema e ambos cadastros com plano de saúde.
Solução
Para que a mensagem não seja apresentada ao processar o envio do leiaute S-1200 deste colaborador, realize os passos a seguir:
1. Acesse Colaboradores / Ficha Cadastral / Consulta Colaboradores;
2. Pesquise pelo nome completo do colaborador para obter os dois cadastros dos registros;
3. Acesse Anuais / Informe/Dirf / Desconto Plano de Saúde / Alterar;
4. Verifique se nesta tela possui valores de plano de saúde (tanto para titular como para dependentes) lançados após o desligamento do cadastro desligado;
5. Posicione sobre o registro indevidos de plano de saúde para o cadastro e exclua o mesmo pressionando CTRL + Delete no teclado;
6. Clique em Gravar para salvar as alterações;
7. Envie o S-1200 novamente.
Caso a situação não se encaixe nesse cenário, é necessário que seja coletado o log do Stack Trace e o log do SQLMon, conforme orientações nos artigos abaixo:
HCM - Monitoramento - Como realizar monitoramento da aplicação utilizando o sqlmon.exe na versão JAVA