HCM – Analytics Ponto – Erro na busca das informações
Incidente
No módulo Senior X, ao tentar acessar acessar os analytics do ponto é exibida a mensagem: Erro na busca das informações. Você pode atualizar a página e, caso o erro continue, deve entrar em contato com o Administrador do sistema.
Causa
Isso ocorre pois a plataforma não está conseguindo acessar os endereços do Gestão do Ponto para obter os dados.
Solução
Para que este incidente não ocorra verifique os itens abaixo:
1.Acese o SeniorConfigCenter, que está localizado no diretório de instalação do sistema;
1.2. Navegue até Sistemas / Gestão de pessoas / Gestão do Ponto;
1.3. Preencha as informações de URL API e Tenant Autorizado;

Para a URL API pode ser preenchido com: https://platform.senior.com.br/t/senior.com.br/bridge/1.0/rest
O tenant pode ser obtido no Senior X em Tecnologia / Administração / Gestão dos Tenants / Configurar.
2. Acesse o menu Chaves no SeniorConfigCenter, e pesquise pela chave abaixo, caso ainda não exista adicione:
com.senior.portal.g7.url
https://platform.senior.com.br/t/senior.com.br/bridge/1.0/rest

3. Acesse o Senior X em Tecnologia / Configuração / Por Tenant;
4. Pesquise pelo domínio HCM; 3.2. Pesquise e abra o serviço hcm / ponto; 3.3. Ao final da tela preencha com as urls e porta do backend e frontend do gestão do ponto;

Importante:
Para que funcione corretamente, é necessário que os pré-requisitos de utilização de HTTPS, URL acessível, Servidor Wildfly com acesso a plataforma sejam atendidos conforme documentação da rotina: Configurar menu na Senior X.
Atenção! Antes de realizar qualquer alteração, analise o impacto que poderá ter em outros lançamentos/processos do sistema.