HCM – S-1000 – 537 - Já existe no sistema registro com mesmo código de identificação (chave) em período de vigência conflitante com o período informado no registro atual. Ação Sugerida: O evento somente pode ser recepcionado se não existir outro evento pa
Incidente
No módulo Administração de Pessoal, ao realizar o envio do leiaute S-1000, é retornada a mensagem: 537 - Já existe no sistema registro com mesmo código de identificação (chave) em período de vigência conflitante com o período informado no registro atual. Ação Sugerida: O evento somente pode ser recepcionado se não existir outro evento para a tabela com o mesmo código de identificação (chave) em período de vigência conflitante com o período informado no evento atual. Certifique-se que o código de identificação e os períodos informados estejam corretos.
Causa
Esta mensagem é retornada, pois já consta no eSocial Produção Restrita um leiaute S-1000 da empresa, e desta forma não é possível realizar o envio do mesmo XML.
Solução
Para que a mensagem não seja retornada ao efetuar o envio do leiaute S-1000, realize os passos a seguir:
Observação:
Os passos abaixo devem ser realizados somente em produção restrita (Homologação), caso ocorra a mesma mensagem em produção é necessário solicitar consultoria para migração de dados com proposta comercial.
1. Acesse o módulo Administração de Pessoal e clique em Empresas / Definições eSocial;
2. Selecione a Empresa a qual está sendo enviado o leiaute S-1000;
2.1. Clique no botão Excluir dados produção restrita:
Importante:
Será gerado um leiaute S-1000 de exclusão. Ao acessar o resumo do leiaute, em Razão Social constará como Remover dados empregador.
3. Acesse eSocial / Consulta Pendências. Caso o leiaute S-1000 esteja para envio manual, marque e envie o mesmo;
3.1. Aguarde o retorno deste leiaute. Ele retornará com o stasit =1 'Erro retornado';
Atenção:
Ao acessar Visualizar Mensagem, constará a informação Dados do empregador foram removidos com sucesso.
4. Acesse eSocial / Gerar Tabelas, marque o leiaute S-1000 e processe;
4.1. Acesse eSocial / Consulta Pendências. Caso o leiaute S-1000 esteja para envio manual, marque e envie o mesmo. O leiaute S-1000 retornará aprovado com sucesso.
Atenção! Antes de realizar qualquer alteração, analise o impacto que poderá ter em outros lançamentos/processos do sistema.