HCM – Provisão – Escala definida está sem horário cadastrado para a data DD/MM/AAAA
Incidente
No módulo Administração de Pessoal, ao realizar o cálculo de provisão, é retornada a mensagem no log para alguns colaboradores: Escala definida está sem horário cadastrado para a data DD/MM/AAAA.
Causa
Esta mensagem é apresentada, pois se trata de algum problema no momento da conversão da antiga rotina para a nova rotina de provisão, fazendo com que os mesmos fossem convertidos com valores zerados, uma vez que na rotina antiga o cálculo está correto. Como a competência calculada é de MM/20XX e os colaboradores apresentados no log foram demitidos em competências anteriores, não existe nenhum valor para provisionar agora, já que não houve cálculo de folha ou rescisão complementar para os mesmos em MM/20XX.
Em análise ao cadastro da escala definida de alguns colaboradores que foram apresentados no log, não foi encontrada nenhuma divergência, ou seja, a mesma está cadastrada corretamente até a competência da rescisão. Desta forma, checamos a tela de consulta das provisões, em Colaboradores / Provisões, onde observamos que a provisão da competência de desligamento destes colaboradores estava gravada com origem O - Conversão, mas sem nenhum valor. Esta situação ocorre somente na rotina nova, na rotina antiga os valores foram baixados corretamente, zerando o saldo dos colaboradores.
Solução
Para que esse incidente não ocorra, realize os passos a seguir:
1. Realize a análise da conversão se esta foi executada corretamente, se o processo foi iniciado e cancelado antes do término. ocasionado os registros inconsistentes;
2. Efetue novamente a conversão da rotina de provisão e recalcule as provisões da competência em questão;
3. Verifique no log que não será mais demonstrada a mensagem referente a escala definida.