Ronda XT – Envio de crachá - Pessoas carregadas sem crachá após carga do Datamart
Incidente
Ao inicializar o serviço Concentradora e, após finalizar a carga do Datamart, ao realizar a consulta de pessoa na CSM Console, foi identificado que as pessoas foram carregadas, porém seu crachá não.
Causa
Esse incidente ocorre, pois existem inconsistências nas tabelas R070CON e/ou R069FIS. A tabela R069FIS não pode conter valor zero, nos campos NUMCRA ou NUMFIS, e não pode haver dois registros com o mesmo número físico (NUMFIS) associados a tecnologias diferentes (por exemplo, Proximidade e SmartCard).
Normalmente, essa situação é consequência de importações realizadas diretamente na tabela R069FIS.
Solução
Para que esse incidente não ocorra, realize os passos abaixo:
1. Verifique registros com valores inválidos (zero) nos campos NUMCRA ou NUMFIS:
- SELECT NUMCRA, NUMFIS FROM R069FIS WHERE NUMFIS = 0;
- SELECT NUMCRA, NUMFIS FROM R070CON WHERE NUMCRA = 0;
2. Valide registros duplicados com mesmo número físico e tecnologias diferentes:
SELECT COUNT(*), A.NUMFIS FROM R069FIS A
WHERE A.NUMFIS IN (
SELECT B.NUMFIS
FROM R069FIS B
WHERE A.NUMFIS = B.NUMFIS
AND A.TECCRA <> B.TECCRA ) GROUP BY A.NUMFIS ORDER BY 1;
3. Analise e ajuste os registros retornados:
-
- Caso existam registros duplicados, exclua um dos registros;
- Alternativamente, é possível manter os dois registros, desde que seja alterado o número físico (NUMFIS) de um deles, garantindo que sejam distintos para tecnologias diferentes;
4. Reinicialize a tabela R070CON, após os ajustes:
4.1. Acesse o menu Supervisão / On-Line / Inicializar Tabelas / Controle/Datamart;
4.2. Execute a rotina de inicialização.
Observação
Essas inconsistências normalmente são causadas por manipulação direta das tabelas de banco de dados. O ideal é realizar os cadastros sempre pelas rotinas do sistema, para evitar impactos futuros.