ERP – eDocs E-mail – O teste foi mal sucedido. Erro retornado: O certificado remoto é inválido, de acordo com o processo de validação
Incidente
Ao cadastrar uma conta de e-mail para envio e/ou recebimento dos documentos eletrônicos e realizar um teste de conexão, é retornado a seguinte informação do servidor de e-mail para o eDocs: O teste foi mal sucedido. Erro retornado: O certificado remoto é inválido, de acordo com o processo de validação.
Essa mensagem também é apresentada no arquivo de log Sde.log na rotina de envio de e-mails.
Causa
Essa situação ocorre no envio/recebimento de e-mail e é uma mensagem padrão retornada pela conexão ao servidor de e-mail SMTP/POP/IMAP.
Ele ocorre por parametrizações inadequadas da conta de envio/recebimento de e-mail, ou no servidor de e-mail.
Solução
Para verificar essa situação deverá ser efetuada as seguintes validações:
1. Valide a parametrização para envio/recebimento de e-mail, se os dados cadastrados corretamente. Para mais informações sobre o cadastro da conta de e-mail, consulte o artigo ERP – eDocs Envio E-mail – Como alterar configurações de envio de e-mails;
2. Verifique com o responsável pela infraestrutura de rede e com o responsável pelo servidor de e-mail utilizado para envio de e-mails os ajustes necessários na infraestrutura ou no servidor de e-mails para que a situação não ocorra;
Observação
- Existem casos onde é necessária a instalação de um certificado digital do servidor de e-mail no ambiente onde o eDocs está instalado. Esta instalação e a correta parametrização é de responsabilidade do profissional que gerencia o ambiente do cliente;
- Caso haja necessidade, devem ser efetuados testes de envio/recebimento a partir de um aplicativo de gerenciamento de e-mails como, por exemplo, Outlook ou Thunderbird;
Em alguns casos, utilizando gerenciadores de e-mail de terceiros, o certificado do servidor de e-mail é considerado inválido, mas o gerenciador pede para continuar utilizando o servidor de e-mail não seguro e o gerenciador de e-mails funciona normalmente. No caso do eDocs, não é possível efetuar tal processo para servidores SMTP, ou seja, não há como ignorar o fato de que o certificado remoto é considerado inválido. Neste caso, existem as seguintes opções para o cliente verificar:
3. Verifique se o seu servidor de e-mail possibilita conexão sem SSL. Se sim, parametrizar o eDocs adequadamente;
4. Instale o certificado do servidor de e-mail no servidor do eDocs.
5. Caso a situação for relacionada a conta de Recebimento de documentos:
5.1. Utilize uma outra conta de outro servidor de e-mail para recebimento, cujo qual o certificado seja considerado válido (ou não necessite de certificado). No e-mail padrão utilizado poderá ser cadastrada uma regra de reencaminhamento de e-mails, para que todos sejam reencaminhados e excluídos da Caixa de Entrada do e-mail original; ou
5.2. Verifique a ativação do parâmetro 'Aceitar certificado inválido' na tela de cadastro de E-mails de Recebimento que é acessada na tela Configurações / Empresas / aba Recebimento / sub-aba E-mail:
Importante
A validação do certificado remoto não é efetuada pelo sistema eDocs, mas sim pelo Sistema Operacional Windows onde o sistema eDocs está instalado. Logo, este problema é estritamente ligado a problema de infraestrutura. Portanto, caso haja necessidade de avaliação da situação, pode-se acionar a área de Serviços da Senior para alocação de um Consultor de TI para avaliação do cenário.