Ronda XT – SmartCard – Não foi possível buscar a chave de logon do SmartCard
Incidente
No módulo Controle de Acesso, ao tentar utilizar funcionalidades que envolvem leitura de SmartCard, é apresentada a mensagem: Não foi possível buscar a chave de logon do SmartCard.
Causa
Esta mensagem é apresentada, pois o Tipo de TBS está incorreto ou faltam definições obrigatórias no SeniorConfigCenter relacionadas às leitoras SmartCard
Solução
Para que a mensagem não seja apresentada, realize as verificações a seguir:
1. Verifique se o Tipo de TBS está definido com valor diferente de 0, acessando o menu Ajuda / Sobre / Sistema;
2. No SeniorConfigCenter, acesse o menu Sistemas / Gestão de Acesso e Segurança / Configuração;
3. Informe o caminho completo do arquivo SmartCard.dll, no campo Arquivo DLL utilizado para a comunicação com leitoras SmartCard Telemática;
4. Confirme se os arquivos chave.cfg e cliente.cfg, fornecidos pela Telemática, estão presentes na pasta de instalação do sistema (Senior / SP);
5. Acesse o menu Sistemas / Ronda Senior / Configurações, dentro do SeniorConfigCenter;
6. Informe o caminho do arquivo chave.cfg, no campo Local do arquivo chave para leitura de crachás SmartCard;
7. Caso esteja utilizando leitoras Digicon, acesse o menu Acesso / Crachás / Leitora de Crachá / Ativação;
8. Clique com o botão direito na leitora desejada;
9. Selecione a opção Propriedades;
10. Preencha o campo Código do mapa smart card.
Observação: Antes disso, é necessário cadastrar o mapa em Acesso / Crachás / Mapa Smart Card.
Atenção! Antes de realizar qualquer alteração, analise o impacto que poderá ter em outros lançamentos/processos do sistema.