HCM – S-2299 – Dia inválido. Ação Sugerida: Deve ser um dia válido de acordo com o calendário anual
Incidente
No módulo Administração de Pessoal, ao tentar enviar o leiaute S-2299, é apresentada a mensagem: Dia inválido. Ação Sugerida: Deve ser um dia válido de acordo com o calendário anual.
Causa
Esta mensagem é retornada, pois o colaborador com contrato intermitente não trabalhou nenhum dia na competência e o campo dia da tag InfoInterm é gerado igual a zero.
Solução
Para o colaborador que teve dias trabalhados na competência da rescisão, realize os passos a seguir para que a mensagem não seja apresentada:
1. Acesse Administração de Pessoal e entre em Colaboradores / Ficha Cadastral / Convocação Intermitente;
1.1. Selecione a convocação referente o período da rescisão do colaborador;
1.2. Clique no botão Horário;
1.3. Selecione a competência da rescisão;
1.4. Informe o horário trabalhado nos dias correspondentes;
2. Acesse Colaboradores / Rescisões / Calcular;
2.1. Recalcule a rescisão do colaborador intermitente;
3. Acesse Cálculos / Ficha Financeira / Cadastro;
3.1. Recalcule a ficha financeira na competência da rescisão do colaborador para ajustar os valores conforme o cálculo da rescisão;
4. Acesse eSocial / Colaboradores / Fechamento de Demissão;
4.1. Informe o período da demissão do colaborador e no campo Status Demissão eSocial utilize a opção Ambas. No botão Seleção filtre somente pelo colaborador e clique no botão Processar;
5. Gere o leiaute S-2299 do colaborador em eSocial / Gerar Não Periódicos;
6. Envie o leiaute S-2299 gerado para o colaborador em eSocial / Consulta Pendências.
Observação: Essa mensagem é somente uma advertência. Se o colaborador não trabalhou nenhum dia na competência da rescisão, pode ignorar a mensagem, pois as informações estão corretas.
Atenção! Antes de realizar qualquer alteração, analise o impacto que poderá ter em outros lançamentos/processos do sistema.