HCM – S-1000 – 537 - Já existe no sistema registro com mesmo código de identificação (chave) em período de vigência conflitante com o período informado no registro atual. Ação Sugerida: O evento somente pode ser recepcionado se não existir outro evento
Incidente
No módulo Administração de Pessoal, ao realizar o processo de exclusão dos dados da produção restrita, o S-1000 de exclusão retorna com a mensagem: 537 - Já existe no sistema registro com mesmo código de identificação (chave) em período de vigência conflitante com o período informado no registro atual. Ação sugerida: O evento somente pode ser recepcionado se não existir outro evento para a tabela com o mesmo código de identificação (chave) em período de vigência conflitante com o período informado no evento atual. Certifique-se que o código de identificação e os períodos informados estejam corretos.
Causa
Esta mensagem é retornada, pois foi realizado o restore do backup da base de produção para a base de homologação e os serviços não foram reiniciados.
Solução
Para que a mensagem não seja retornada, realize os passos a seguir:
1. Acesse os Serviços e reinicie o Senior Documentos Eletrônicos (SDE) de homologação;
2. Entre no módulo Administração de Pessoal e clique em eSocial / Consulta Pendências;
3. Informe um número de recibo fictício para o S-1000 que está com erro;
4. Acesse em Empresas / Definições eSocial e clique no botão Excluir dados produção restrita;
5. Entre em eSocial / Gerar Tabelas e faça a geração;
6. Informe um número de recibo fictício para o S-1000 que está com erro;
7. Acesse em Empresas / Definições eSocial e clique no botão Excluir dados produção restrita;
8. Entre na tela de consulta pendência e aguarde o S-1000 retornar com a mensagem: 1012 - O Empregador XX foi removido com sucesso da base de dados da produção restrita do eSocial.
9. Inicie os envios novamente.
Atenção! Antes de realizar qualquer alteração, analise o impacto que poderá ter em outros lançamentos/processos do sistema.