HCM – Hierarquia de Postos de Trabalho – O posto de trabalho não está na hierarquia atual
Incidente
Na plataforma SeniorX, ao tentar consultar um colaborador, é apresentada a mensagem: O posto de trabalho não está na hierarquia atual.
Causa
Essa mensagem é apresentada porque há mais de um colaborador alocado em um posto de trabalho de gestão. Isso impede todas as integrações da hierarquia, independentemente do posto de trabalho envolvido, pois é pré-requisito da plataforma que o posto de trabalho de gestor tenha apenas um ocupante.
No Dashboard do HCM, ao acessar a aba Integração, no item "O que está acontecendo", é possível visualizar logs com mensagens como:
"O posto de liderança XXXX da empresa YYYY está sendo ocupado por mais de um colaborador."
Essa situação bloqueia a sincronização da hierarquia e deve ser corrigida diretamente no módulo Administração de Pessoal (XT), ajustando a alocação dos colaboradores nos postos de liderança.
Solução
Para verificar os ocupantes do posto incorreto, realize os seguintes passos:
1. Acesse o Administração de Pessoal (XT) em Tabelas / Postos de Trabalho / Hierarquia / Hierarquia de Postos;
1.1. Escolha a estrutura de postos utilizada pela empresa;
1.2. Selecione o tipo de hierarquia correspondente;
1.3. Localize o posto indicado no Dashboard;
1.4. Utilize a função Consulta de ocupação de Postos de trabalho clicando com o botão direito do mouse em cima do posto;
1.5. Localize os colaboradores do posto;
1.6. Ajuste os ocupantes do posto, para que apenas um colaborador ocupe o posto de liderança.