HCM - Apuração de colaboradores - Situação de falta que não aparece na tela de acertos
Incidente
No módulo Gestão do Ponto, ao verificar os totais do colaborador, é apresentado horas faltas, sendo que as mesmas não aparecem na tela de acertos.
Causa
Este incidente ocorre, pois foi apurado situações de faltas para o colaborador e depois foi alterado os históricos e data de admissão através do banco de dados.
Solução
Para que o incidente não ocorra, realize os passos a seguir:
1. Abra o CBDS;
2. Realize um select na tabela R038HFB:
SELECT * FROM R038HFB WHERE NUMEMP = XX AND NUMCAD = XXX.
2.1. Verifique se houve troca na data de admissão, campo DATADM:
3. Realize um select na tabela R066SIT:
SELECT * FROM R066SIT WHERE NUMEMP = XX AND NUMCAD = XXX AND DATAPU = DAY (AAAA,MM,DD);
3.1. Verifique se contem algum lançamento anterior a data de admissão do colaborador:
4. Caso tenha lançamento realize um delete conforme abaixo, para estes dias apurados incorretamente, antes da data de admissão:
DELETE R066SIT WHERE NUMEMP = XX AND NUMCAD = XXX AND DATAPU = DAY (AAAA,MM,DD) AND CODSIT = XX;
5. Verifique novamente os totais do colaborador no menu Acertos da minha equipe, selecione o colaborador e clique em Totais.
Atenção! Antes de realizar qualquer alteração, analise o impacto que poderá ter em outros lançamentos/processos do sistema.