ERP – Manutenção de Pedidos – Na rotina de Exclusão e Cancelamento de Pedido ao tentar mostrar os dados é apresentada a mensagem: Nenhum registro selecionado
Incidente
No processo de Manutenção de Pedidos ao tentar excluir o saldo de pedidos, via tela F120CAN - Mercado / Gestão de Vendas / Pedidos / Manutenção de Pedidos / Exclusão e cancelamento (Exclusão e Cancelamento de Pedidos), é apresentada a mensagem: Nenhum registro selecionado.
Causa
Essa mensagem ocorre porque não estão sendo atendidas as condições do comando que é realizado, para mostrar os dados em tela.
As condições devem ser verificadas, para que seja possível mostrar os dados tela.
- As transações do pedido devem ser '90100','90101','90105' ou 90100','90101','90105';
(E120PED.TNSPRO IN ('90100','90101','90105') OR
E120PED.TNSSER IN ('90100','90101','90105')) AND;
- A situação do item de pedido, quando for produto, não pode ser 8, Preparação Análise o NF, e o campo E120IPD.GerNec não pode ser 2 e 3;
(E120IPD.SITIPD = 8 OR
E120IPD.GERNEC IN (2,3)))) AND;
- A situação do item de pedido, quando for serviço, não pode ser 8, Preparação Análise o NF, o pedido deve existir na base, e a situação do pedido não pode ser 1 e 2;
E120ISP.SITISP = 8)) AND
(( (E120PED.NUMPED = 550) )) AND
E120PED.SITPED IN (1,2).