SENIOR X PLATFORM - Notificações - Não é possível acessar as notificações da plataforma com mais de 30 dias
Incidente
Na tela de notificações da Plataforma Senior X, ao tentar visualizar as notificações superiores aos últimos 30 dias, essas não são mostradas, ou seja, as notificações além de 30 dias não são mais apresentadas na tela.
Causa
Essa situação ocorre porque há uma configuração da Plataforma, que define o tempo padrão, que as notificações ficarão armazenadas para visualização dos usuários.
Por padrão, na criação dos Tenants esta configuração é definida para realizar este armazenamento durante 30 dias, entretanto é possível realizar a alteração deste tempo de acordo com sua necessidade.
Solução
Para realizar a alteração do valor padrão de apresentação das notificações, realize os passos abaixo:
1. Acesse a Plataforma Senior X com o usuário admin;
2. Entre no menu Tecnologia / Configuração / Por Tenant;
3. Na tela de Configurações Gerais, desça a tela até a sessão de domínios / Serviços e busque pelo domínio Platform, conforme imagem abaixo:
4. Expanda o domínio Platform e faça um filtro pelo serviço Notifications, conforme demonstrado a seguir:
5. Clique no botão Editar, para alterar as configurações do serviço de notificações;
6. Na tela de propriedades do serviço, selecione a aba Sistema:
7. Encontre o campo platform.configuration.notification_retention_days e altere o valor para a quantidade de dias que as notificações devem ficar disponíveis:
8. Clique no botão Salvar para gravar as alterações. A partir deste momento as notificações serão armazenadas pelo período de tempo informado conforme definição do campo mencionado.
Atenção! Antes de realizar qualquer alteração, analise o impacto que poderá ter em outros lançamentos/processos do sistema.