ERP - Emissão de NFS-e - Não foi possível fechar a nota fiscal de saída - Itens de serviço possuem diferenças nos seguintes campos Serviço Base
Incidente
No módulo de Mercado, ao emitir a nota ou incluir um pedido de serviços, é apresentada a mensagem: Não foi possível fechar a nota fiscal de saída - Itens de serviço possuem diferenças nos seguintes campos Serviço Base XX
Serviço código XX.
Causa
Essa mensagem é apresentada, pois foram inclusos serviços com informações tributárias diferentes. Com a entrada da Reforma Tributária, as informações tributárias devem permanecer iguais entre os serviços de uma mesma nota fiscal.
Solução
Para que a mensagem não seja apresentada, realize os passos abaixo:
1. Realize o recálculo da nota e veja se a mensagem permanece;
2. Acesse a tela F080SER - Cadastros / Produtos e Serviços / Serviços / Individual;
3. Confirme se Código de Tributação Nacional, Código de Tributação do Serviço, Código NBS, Tipo de Serviço, Percentual de ISS, Código Fiscal Municipal e o campo cClassTrib da Reforma Tributária, são os mesmos para todos os serviços informados;
4. Separe o serviço que estiver com a informação tributária diferente em outra nota fiscal;
5. Emita a nota ou finalize o pedido normalmente.
Importante
Com a entrada da Reforma Tributária, as informações tributárias devem permanecer iguais entre os serviços de uma mesma nota fiscal.
O sistema passa a comparar automaticamente campos como Código de Tributação Nacional, Código de Tributação do Serviço, Código NBS, Tipo de Serviço, Percentual de ISS, Código Fiscal Municipal e o campo cClassTrib da Reforma Tributária.
No Pedido de Venda (F120GPD), ao fechar pedidos com múltiplos itens de serviço, o sistema realiza a validação e apresenta um aviso informativo caso existam divergências entre os serviços. Nesse processo, a operação não é bloqueada e itens cancelados são desconsiderados da validação.
No Faturamento em Lote (F140LOT), durante o processamento de pedidos para emissão de NFS-e, o sistema valida automaticamente os itens de serviço. Caso sejam encontradas divergências tributárias, o faturamento é bloqueado até que os dados sejam corrigidos.
Na Nota Fiscal de Saída (F140GNF), ao inserir itens de serviço, o sistema exibe um aviso informativo quando houver diferenças em relação ao primeiro item da nota. Já no fechamento da nota fiscal, caso permaneçam divergências entre os serviços, o fechamento da NFS-e é bloqueado até a regularização das informações.
As mensagens foram unificadas para apresentar de forma mais clara quais serviços possuem divergências e quais campos estão inconsistentes, facilitando a identificação e correção dos dados antes da emissão da NFS-e.
Abaixo, um resumo do comportamento do sistema:
| Situação | Tipo de mensagem | Bloqueia operação? |
|---|---|---|
| Pedido de venda com serviços divergentes | Aviso | Não |
| Inserção de item na nota com divergência | Aviso | Não |
| Faturamento em lote (NFS-e) com divergência | Erro | Sim |
| Fechamento da nota fiscal (NFS-e) com divergência | Erro | Sim |
| Apenas 1 item de serviço | Nenhuma | Não |
| Itens cancelados no pedido | Ignorados | Não |
Locais:
Mercado / Gestão de Faturamento e Outras Saídas / Notas Fiscais de Saída / Digitação de notas manuais (F140GNF);
Mercado / Gestão de Faturamento e Outras Saídas / Notas Fiscais de Saída / Via Pedido / Agrupado (F140LOT);
Mercado / Gestão de Vendas / Pedidos / Agrupado (F120GPD).