ERP - Emissão NFS-e - Não foi possível integrar o arquivo (\senior01\senior\sapiens\xml\condovita\Processado\Nfse\NFSXXXXXXXXXXXX_XXXXXXXXXXXXX.xml): O arquivo não segue o formato esperado. The 'http://www.sped.fazenda.gov.br/nfse:cIndOp' element is inval
Incidente
No módulo Mercado, ao emitir a nota fiscal de serviço, é apresentada a crítica: Não foi possível integrar o arquivo (\senior01\senior\sapiens\xml\condovita\Processado\Nfse\NFSXXXXXXXXXXXX_XXXXXXXXXXXXX.xml): O arquivo não segue o formato esperado. The 'http://www.sped.fazenda.gov.br/nfse:cIndOp' element is invalid - The value '' is invalid according to its datatype 'http://www.sped.fazenda.gov.br/nfse:TSRTCCodIndOp' - The Pattern constraint failed.
Causa
Este incidente ocorre, pois não foi informado o Indicador de Operação (IndOp) na emissão da Nota Fiscal de Serviço Eletrônica (NFS-e). O Indicador de Operação é um campo obrigatório para a emissão da NFS-e.
Solução
Para que a mensagem não seja apresentada, realize os passos a seguir:
Para informar o Indicador de Operação, ou seja, o IndOp, manualmente, realize os passos abaixo:
Acesse tela F140GNF_RFNF - Mercado / Gestão de Faturamento e Outras Saídas / Notas Fiscais de Saída / Digitação de Notas manuais;
Busque a nota;
Clique no botão Diversos;
Informe o Indicador de Operação, no campo Indicador dA Operação NFS-e.
Para que o indOp seja sugerido de forma automática para o pedido, deve seguir algumas premissas que estão documentadas no ajuda da tela F027NOP:
Critérios para Sugestão do IndOp:
A sugestão ocorre no momento da geração da NFS-e, ao informar o serviço na nota.
Quando o campo Serviço Prestado Fisicamente = S (Sim)
O sistema sugere automaticamente:
A informação no botão Diversos da nota;
O IndOp conforme os critérios abaixo.
Cenário 1 – Destinatário Serviço Prestado Informado
Quando houver um código informado no campo Destinatário Serviço Prestado, o sistema definirá automaticamente o Local da Prestação de Serviço = 3, e o respectivo Indicador da Operação (IndOp) conforme o relacionamento configurado na F027NOP.
Acesse a tela Notas Fiscais de Saída (F140GNF);
Informe o serviço normalmente na nota;
Acesse o botão Diversos;
No campo Destinatário Serviço Prestado, informe manualmente o código do cliente.
Após informar o destinatário, o sistema:
Define automaticamente Local da Prestação de Serviço = 3;
Sugere o Indicador da Operação (IndOp) conforme o relacionamento configurado na F027NOP.
Exemplo
Se o vínculo para Local 3 estiver associado ao IndOp 050103, esse código será carregado automaticamente.
Cenário 2 – Município da Filial = Município do Cliente
(Comparação pelo Cod.RAIS/Cod.IBGE)
Quando o município da filial for igual ao município do cliente, o sistema definirá automaticamente o Local da Prestação de Serviço = 1, e o respectivo IndOp conforme o relacionamento configurado na F027NOP.
Acesse a tela Notas Fiscais de Saída (F140GNF).
Informe o serviço normalmente na nota.
Clique no botão Diversos.
Certifique-se de que o campo Serviço Prestado Fisicamente esteja definido como S (Sim), conforme cadastro do cliente.
O sistema realiza automaticamente a comparação entre:
Cod.RAIS/Cod.IBGE da Filial
Cod.RAIS/Cod.IBGE do Cliente
Quando os códigos forem iguais, o sistema:
Define automaticamente Local da Prestação de Serviço = 1;
Sugere o Indicador da Operação (IndOp) correspondente ao vínculo configurado na F027NOP.
Exemplo
Se o relacionamento para Local 1 estiver vinculado ao IndOp 050101, esse código será carregado automaticamente no campo Indicador da Operação NFS-e.
Cenário 3 – Município da Filial ≠ Município do Cliente
(Comparação pelo Cod.RAIS/Cod.IBGE)
Quando o município da filial for diferente do município do cliente, o sistema definirá automaticamente o Local da Prestação de Serviço = 2, e o respectivo IndOp conforme o relacionamento configurado na F027NOP.
Acesse a tela Notas Fiscais de Saída (F140GNF).
Informe o serviço normalmente na nota.
Clique no botão Diversos.
Certifique-se de que o campo Serviço Prestado Fisicamente esteja definido como S (Sim), conforme cadastro do cliente.
-
O sistema realiza automaticamente a comparação entre:
Cod.RAIS/Cod.IBGE da Filial
Cod.RAIS/Cod.IBGE do Cliente
Quando os códigos forem diferentes, o sistema:
Define automaticamente Local da Prestação de Serviço = 2;
Sugere o Indicador da Operação (IndOp) correspondente ao vínculo configurado na F027NOP.
Exemplo
Se o relacionamento para Local 2 estiver vinculado ao IndOp 050102, esse código será carregado automaticamente no campo Indicador da Operação NFS-e.![]()
Cenário 4 – Serviço Prestado Fisicamente = N (Não)
Quando o campo Serviço Prestado Fisicamente (S/N) estiver definido como N (Não) no cadastro do cliente, ou estiver em branco, o sistema considerará que o serviço não foi prestado fisicamente.
Nesse caso, o Local da Prestação de Serviço = 0 – Nenhum, e o respectivo IndOp serão sugeridos automaticamente conforme o relacionamento configurado na F027NOP.
Acesse a tela Notas Fiscais de Saída (F140GNF).
Informe o serviço normalmente na nota.
Clique no botão Diversos.
Verifique o campo Serviço Prestado Fisicamente:
Se estiver definido como N (Não) no cadastro do cliente, essa informação será carregada automaticamente na nota.
Caso o campo esteja em branco no cadastro do cliente, permanecerá em branco na nota.
Nessa condição, o sistema:
Define automaticamente Local da Prestação de Serviço = 0 – Nenhum;
Sugere o Indicador da Operação (IndOp) vinculado ao Local 0 na tela F027NOP.
Exemplo
Se o Local 0 estiver relacionado ao IndOp 100301, esse código será carregado automaticamente no campo Indicador da Operação NFS-e.
Atenção! Antes de realizar qualquer alteração, analise o impacto que poderá ter em outros lançamentos/processos do sistema.