ERP MEGA – Busca por CNPJ Agentes – Usuário sem acesso à rotina Busca por CNPJ via API
Incidente
No ERP MEGA, integrado à Senior Platform, um usuário não consegue acessar a rotina “Busca por CNPJ – Receita”, enquanto outros usuários conseguem acessar normalmente a mesma funcionalidade.
Causa
Este incidente ocorre, pois o usuário que não consegue acessar não possui todas as permissões necessárias configuradas no papel “MEGAXT Usuário Padrão”.
Solução
Para permitir o acesso à rotina Busca por CNPJ – Receita, realize os passos a seguir:
1. Acesse a Senior Platform com um usuário administrador;
2. Navegue até o cadastro de Papéis;
3. Localize e acesse o papel “MEGAXT Usuário Padrão”;
4. Acesse a aba Permissões;
5. No domínio Platform / Dataset, habilite as seguintes permissões:

“Editar + Visualizar do Dataset”;
“Editar + Visualizar do Datasource”;
6. Salve as alterações;
7. Solicite que o usuário realize novo acesso ao ERP MEGA.
Atenção! Antes de realizar qualquer alteração, analise o impacto que poderá ter em outros lançamentos/processos do sistema.