ERP – Senior X/Requisição Eletrônica – Não é possível requisitar um serviço como produto ou vice-versa
Incidente
No processo de envio de uma Requisição Eletrônica da Plataforma Senior X para o Gestão Empresarial | ERP G5, a requisição não é integrada e a seguinte mensagem é gerada: Ao enviar uma requisição eletrônica para aprovação, ocorre o seguinte erro: A requisição XX não foi integrada. COntate o suporte informando a seguinte mensagem de erro: [Service: ig5_requisicao.erp_sup; Primitive: integrarRequisicao; Category UNPROCESSABLE; code: ] Não é possível requisitar um serviço como produto ou vice-versa.
Causa
Essa situação ocorre porque o tipo do produto está incorreto no Gestão Empresarial | ERP G5
Solução
Abaixo seguem as ações a serem realizadas para ajuste dessa situação.
1. Faça a seguinte consulta no banco de dados:
SELECT TIPPRO FROM E075PRO WHERE CODPRO = /*CÓDIGO DO SERVIÇO*/ AND CODEMP = /*CÓDIGO DA EMPRESA*/
1.1. Caso você esteja requisitado um serviço:
1.2.1. Neste caso, o campo 'E075PRO.TipPro' deve estar como 'S'. Se estiver diferente disso, então faça um update para corrigir:
UPDATE E075PRO SET TIPPRO = 'S' WHERE CODPRO = /*CÓDIGO DO SERVIÇO*/ AND CODEMP = /*CÓDIGO DA EMPRESA*/
1.2. Caso você esteja requisitando um produto:
1.2.1. Neste caso, o campo 'E075PRO.TipPro' deve estar diferente de 'S'. Neste caso, o campo deverá ter um dos tipos abaixo:
- P - Produzido;
- C - Comprado;
- M - Montagem;
- D - Passagem Direta.
Abaixo segue exemplo de comando para ajuste, onde você deve alterar o XX pelo indicativo correto.
UPDATE E075PRO SET TIPPRO = 'XX' WHERE CODPRO = /*CÓDIGO DO SERVIÇO*/ AND CODEMP = /*CÓDIGO DA EMPRESA*/
2. Após o ajuste no cadastro do produto/serviço, reenvie a requisição pelo Senior X.