HCM – Banco de Horas – Saldo de banco de horas antes da admissão
Incidente
No módulo Controle de Ponto ou Gestão do Ponto, está sendo demonstrado saldo de banco de horas antes da data de admissão do colaborador nos relatórios ou manutenção do banco de horas.
Causa
Este incidente ocorre, pois o colaborador foi cadastrado com uma data de admissão, e depois esta data foi alterada.
Verificando a tabela R038HFB, somente via Select, é possível ver a alteração da data de admissão do colaborador.
Este cadastro errado fez com que alguns dias fossem apurados com horas faltas indevidamente e entrou este saldo para o banco de horas. Nestes casos a apuração deve ser zerada antes de mudar a data de admissão.
Solução
Para que esse incidente não ocorra, realize os passos a seguir:
1. Acesse o módulo Controle de Ponto e clique em: Colaboradores / Ficha Cadastral / Empregados;
1.1. Altere a data de admissão para a data errada novamente.
2. Execute a rotina de apuração, em: Controle de Ponto / Diversos / Utilitários / Zerar Apuração;
2.1 Altere a data de admissão do colaborador para a data correta no seguinte caminho: Colaboradores / Ficha Cadastral / Empregados.
Importante: Se dados deste colaborador já foram enviados para o eSocial, o sistema não vai deixar realizar esta alteração, neste caso a correção poderá ser efetuada somente via banco de dados pelo seu TI, DBA ou time de serviços Senior.
Atenção! Antes de realizar qualquer alteração, analise o impacto que poderá ter em outros lançamentos/processos do sistema.