ERP – eDocs Licenças – Não foi possível consultar a proprietária. Tentando carregar do cache. Detalhes: There was no endpoint listening at https://licenciamento.senior.com.br:8988/Licenca/Consulta that could accept the message
Incidente
Ao acessar a tela Configurações / Licenças e clicar no botão Atualizar licença, as seguintes mensagens poderão ser apresentadas ao usuário:
- Erro ao validar a proprietária;
- No Log do Monitor (Monitor.log) são encontradas mensagens como:
- WARN Senior.SapiensNfe.Processos.Sistema.Proprietaria.WebService.Licenca - Não foi possível consultar a proprietária. Tentando carregar do cache. Detalhes: There was no endpoint listening at https://licenciamento.senior.com.br:8988/Licenca/Consulta that could accept the message. This is often caused by an incorrect address or SOAP action. See InnerException, if present, for more details;
- WARN Senior.SapiensNfe.Processos.Sistema.Proprietaria.WebService.Licenca - Não foi possível consultar a proprietária. Tentando carregar do cache. Detalhes: Erro ao fazer a solicitação HTTP para https://licenciamento.senior.com.br:8988/Licenca/Consulta. Isso pode estar relacionado ao fato de o certificado de servidor não estar corretamente configurado com HTTP.SYS no caso HTTPS. Isso também pode ter sido causado por uma incompatibilidade da associação de segurança entre o cliente e o servidor.
- Ao consultar a URL de licenciamento no navegador, a consulta é retornada desta forma:
- No Monitor, também pode ser apresentado críticas de integração dos documentos. Exemplo: Verifique a licença, a filial XX - EMPRESA TESTE não possui autorização para NF-e.
Causa
Essa situação ocorre por problemas relacionados a infraestrutura no servidor onde o serviço do eDocs está instalado.
Solução
Para verificar essa situação, siga as orientações abaixo:
1. Para validar a comunicação do eDocs com o Servidor de Licenças da Senior, verifique o artigo ERP – eDocs Licenças – Como verificar se o eDocs está conseguindo validar corretamente a licença de uso do sistema;
2. Após os ajustes efetuados conforme artigo citado acima, acesse a tela Configurações / Licenças e efetue a atualização da licença novamente.