HCM – Abrangências – Perspectivas na central de segurança indisponíveis ou desorganizadas
Incidente
No módulo Controle de Ponto e Refeitório, ao tentar acessar a aba de Perspectivas dentro da central de segurança, ela não está acessível, ou menus estão fora de ordem.
Causa
Este incidente ocorre, pois houve uma falha na instalação do Gestão de Ponto, na rotina de realizar a exportação das perspectivas através do Glassfish que é feito pelo instalador.
Solução
Para que este incidente não ocorra, realize os passos a seguir:
1. Acesse o CBDS, que pode ser encontrado dentro da pasta Vetorh do diretório de instalação do sistema;
2. Realize o login no CBSD em Arquivo / Conectar;
3. Acesse o menu Ferramentas / Editor SQL;
4. Realize o select para retornar o valor do campo Prmid:
SELECT * FROM R900GPR WHERE PRMID = 67
Importante
Caso o PrmVal for false ou não exista o registro, ele deve ser incluído/alterado para o valor TRUE.
Para alterar o valor para TRUE, realize o comando a seguir:
UPDATE R900GPR SET PRMVAL = 'TRUE' WHERE PRMID = 67
Observação
Caso não contenha o registro, deve ser incluída uma linha com a informação.
Para incluir a linha, execute o comando a seguir:
INSERT INTO R900GPR (PRMID,PRMVAL) VALUES (67,'TRUE')
5. Limpe as perspectivas executando o comando:
DELETE R980PER WHERE PERCTX <> 'SeniorMonitorCenter'
6. Exporte as perspectivas novamente acessando a URL: http://servidor:porta/gestaoponto/installer/exportPerspectives
Importante
Troque http://servidor:porta pelo nome do servidor e porta utilizados para acessar o Gestão do Ponto.
Ao final dos procedimentos verifique que as perspectivas devem ter sido organizadas novamente.
Atenção
Os comandos devem ser executados por alguém com conhecimento em banco de dados.