ERP – eDocs Certificado Digital – O certificado não foi considerado válido. Verifique a cadeia de certificados e se o usuário que está rodando a aplicação tem acesso à internet
Incidente
Ao importar o certificado digital pelo campo 'Configurar certificado' na tela Configurações / Empresas, menu Geral ou pelo campo 'Configurar certificado' na tela Configurações / Filiais, menu Filial, sub-menu Geral, e clique no botão Detalhes do certificado é apresentado a seguinte mensagem: O certificado não foi considerado válido. Verifique a cadeia de certificados e se o usuário que está rodando a aplicação tem acesso à internet. Esse comportamento pode gerar problemas, porém não impede a utilização desse certificado.
Causa
Essa situação ocorre quando o eDocs não consegue realizar o reconhecimento do Certificado Digital no IIS (Internet Information Services) ou por alguma falta de permissão no ambiente onde o eDocs está instalado (necessitando de liberação das URLs utilizadas para que o certificado digital tenha sua validade consultada, sob demanda no proxy/firewall da empresa).
Solução
Para que a mensagem não seja apresentada, é necessário revisar as parametrizações do IIS no servidor onde se encontra a instalação dos serviços do eDocs. Siga os seguintes passos:
1. Acesse o artigo ERP – eDocs Configurações – Como realizar a parametrização adequada do IIS (Internet Information Services) no servidor de instalação do eDocs;
2. Realize a configuração adequada do IIS no Servidor onde o Monitor está instalado, conforme documentação.
Observação
- Em caso de necessidade de apoio para realizar a configuração, solicite apoio para o profissional da sua empresa responsável pelo gerenciamento dos Servidores Windows;
- Caso você utilize ambiente Cloud Senior, essas configuração são efetuadas pela equipe de IT Services da Senior. Um ticket poderá ser gerado para IT Services solicitando revisão dessas configurações;
- A mensagem retornada não impede a utilização do certificado digital, ou seja, os documentos podem ser transmitidos corretamente em alguns cenários;
- A situação trata-se de parametrização do ambiente, ou seja, não trata-se de uma falha no sistema eDocs.
Importante
Com relação as URLs utilizadas para validação do certificado digital, verifique o artigo ERP - eDocs Certificado Digital - Quais são as URLs que o sistema eDocs utiliza para fazer a validação de um Certificado Digital instalado em uma Empresa ou Filial?