ERP - Integração Decision Center/Gestor Senior – O usuário e senha podem estar inválidos ou o token de autorização não consegue ser renovado / Não foi possível efetuar o login no tenant com o accessKey e o secret informados... Razão [400] Requisição falha
Incidente
No processo de integração com Decision Center/Gestor Senior, o processo agendado de integração é executado e gera uma das seguintes mensagens:
- Não foi possível autenticar no serviço do Workflow 2.0 após algumas tentativas. O usuário e senha podem estar inválidos ou o token de autorização não consegue ser renovado. Mensagem original: <ams:fault xmlns:ams="http://wso2.org/apimanager/security"><ams:code>XXXXXXXXX</ams:code><ams:message>Invalid Credentials</ams:message><ams:description>Access failure for API: /t/senior.com.br/bridge/1.0, version: 1.0. Make sure your have given the correct access token</ams:description></ams:fault>
- Não foi possível efetuar o login no tenant com o accessKey e o secret informados... Razão [400] Requisição falha. Código de integração: loginWithKeyResponse
Causa
Esse incidente ocorre devido a chaves incorretas parametrizadas no SeniorConfigCenter.
Solução
Para solucionar esse incidente execute os processos abaixo:
1. Acesse a Plataforma Senior X com usuário administrador do Tenant da sua empresa;
1.1. Acesse o menu Tecnologia / Administração / Gerenciamento de aplicações;
1.2. Localize a aplicação na qual está vinculada a parametrização da integração com o aplicativo de mobilidade. Exemplo de aplicação: Decision-Center ou seniorx-application;
1.2.1. Clique no botão Ações e selecione a opção Gerar chave. Esse processo gerará a Chave de acesso da aplicação e a Senha da aplicação
1.2.2. Copie as informações geradas.
2. Acesse o SeniorConfigCenter;
2.1. Acesse o menu Plataforma XT / Configuração de integração;
2.2. Defina adequadamente a chave de acesso e a chave secreta, conforme geração efetuada através da Plataforma:
3. Após salvar as chaves, reinicie o serviço do Middleware.
- Caso você possua o sistema em ambiente Cloud Senior, os passos do tópico 2 devem ser executados pela equipe de IT Services. Para isso, gere um ticket solicitando a execução desses passos.
- Verifique internamente a necessidade de realizar a atualização de configuração de outros aplicativos que por acaso fazem login na Plataforma Senior X utilizando a mesma chave de acesso que você solicitou a re-geração. Neste caso, você deve atualizar a chamada a partir desses aplicativos também.