ERP – eDocs Impressão – Solicitação indevida de reimpressão em lote de NF-e
Incidente
Na tela NF-e / Emissões, aba Emissões, o usuário realizou um filtro incorreto no eDocs e acidentalmente clicou no botão Todos os documentos filtrados, fazendo com que todos os DANFES fossem enviados novamente impressão.
Causa
A situação é causada pelo processo incorreto da solicitação de impressão realizado pelo usuário sem informar o filtro corretamente no Monitor do eDocs.
Solução
Importante
Esse artigo se refere apenas para processo de Impressão, onde o eDocs envia arquivos para impressão ao PrintService. Para informações sobre essa ocorrência quando utiliza-se Impressão Remota, verifique o artigo ERP - eDocs Impressão Remota - Solicitação indevida de reimpressão em lote de NF-e.
1. Primeiramente é necessário que você pare o serviço do eDocs, para que a execução do serviço em segundo plano seja finalizado com falha;
1.2 No Servidor do eDocs, logando na máquina com o mesmo usuário que está instanciando os serviços, acesse o Configurador do eDocs ou abra o Services.msc do Windows e localize o serviço do eDocs:
2. Caso o processamento em segundo plano já tenha finalizado, para verificar os documentos pendentes de impressão efetue os seguintes comandos:
2.1 Acesse o banco de dados do eDocs, e realize os seguintes selectss:
2.1.1. Comando para NF-e 3.10 e 4.0:
SELECT
*
FROM
N130NFE
WHERE
SITIMP = 1
2.1.2. Comando para NF-e 2.00:
SELECT *
FROM
INTERF_NFE
WHERE
IND_EMIS_DANFE = 1
Para alterar o status de impressão, efetue update no campo SITIMP para 2 ou 3.
Onde:
SITIMP: Indicativo de emissão de DANFE (1-pendente / 2-impressa/ 3 - Desativado / 4-Impresso Contingência / 5-Impressão Temporária);
2.2. Exemplo de comando para NF-e 3.10 e 4.0:
UPDATE
N130NFE
SET
SITIMP = 2
WHERE
SITIMP = 1
2.2 Comando para NF-e 2.00:
UPDATE
INTERF_NFE
SET
IND_EMIS_DANFE = 2
WHERE
IND_EMIS_DANFE = 1
3. Após executar o comando, reinicie o spooler de impressão nos serviços do Windows;
4. Finalizado os processos, inicie novamente o serviço do eDocs.