ERP - eDocs Impressão Remota - Solicitação indevida de reimpressão em lote de NF-e
Incidente
Na tela NF-e / Emissões, aba Emissões, o usuário realizou um filtro incorreto no eDocs e acidentalmente clicou no botão Todos os documentos filtrados, fazendo com que todos os DANFES fossem enviados novamente impressão.
Causa
A situação é causada pelo processo incorreto da solicitação de impressão realizado pelo usuário sem informar o filtro corretamente no Monitor do eDocs.
Solução
Importante
Esse artigo se refere apenas para processo de Impressão Remota, onde o PrintService fica consultando o eDocs via WebService em busca de documentos que precisam ser impressos. Para informações sobre essa ocorrência quando utiliza-se Impressão Convencional (não remota), verifique o artigo ERP – eDocs Impressão – Solicitação indevida de reimpressão em lote de NF-e.
Para resolver essa situação siga os passos abaixo:
1. No banco de dados do eDocs execute o comando:
SELECT MAX(SEQPIM) FROM N100PIM;
2. Salve o valor apresentado no resultado. Ele indica o último número atribuído em NF-e para impressão;
3. Para o Serviço do PrintService;
4. Acesse o diretório de instalação do PrintService, exemplo C:\Senior\SDE\nome_instalação\PrintService;
4.1. Dentro da pasta abra o arquivo Senior.SapiensNfe.PrintService.exe.config;
4.2.. Busque a tag <add key="NsuImpressao" value="0" />;
4.3. No campo value="", coloque o valor salvo do select. Exemplo
<add key="NsuImpressao" value="155" />
5. Inicie novamente o serviço do PritnService e acompanhe as impressões.
Observação
Caso a empresa possua licença SAAS (ambiente Cloud da Senior), entre em contato com a equipe de Suporte de IT Services para realização do procedimento de comandos no banco de dados;
Caso sua empresa possua licença SAAS (ambiente Cloud da Senior), o PrintService está instalado no ambiente da sua Empresa. Portanto, as alterações relacionadas ao PrintService devem ser realizado por vocês, após a equipe de IT Services indicar o valor de retorno do comando select do tópico 1.