ERP - Visões Contábeis - Não gera valores na visão contábil ou gera valores incorretos
Incidente
No módulo Gestão de Contabilidade, ao tentar consultar a visão contábil, os valores não são apresentados ou gera valores incorretos.
Causa
Este incidente ocorre, pois o sistema busca da tabela E650SAL da conta contábil, os valores do último registro contido dentro da abrangência do período informado na visão. Quando não há registro na tabela E650SAL o saldo é apresentado como zero.
Ou ainda, em um cenário específico, a visão contábil está configurada como visão normal, não desconsidera o zeramento e na composição está utilizando uma conta contábil que busca os movimentos do período.
Solução
Para que esse incidente não ocorra, realize os passos a seguir:
1. Acesse a tela F650CCT - Controladoria / Gestão de Contabilidade / Contabilidade / Conciliação / Saldos (Conciliação Contábil) e realize o processo de corrigir os saldos contábeis, definindo o período inicial igual o da visão até a data atual;
Importante:
Para executar a rotina de conciliação de saldos contábeis da forma correta, acesse o artigo ERP – Conciliação Contábil – Como executar a rotina de conciliação de saldo contábeis.
2. Acesse a tela F046CVI - Controladoria / Gestão de Contabilidade / Visões Contábeis / Consultas (Consulta de Visões Contábeis) e gere a visão contábil normalmente.
Observação:
- Esse processo irá corrigir a tabela E650SAL responsável por guardar as informações dos saldos por mês. Dessa forma, a consulta da visão contábil irá apresentar os valores corretamente.
Ou, para o cenário específico citado na causa:
1. Acesse a tela F650CLC - Controladoria / Gestão de Contabilidade / Contabilidade / Consultas / Lançamentos / Contábil (Consulta de Lançamentos Contábeis), filtre a conta contábil e o período em que gostaria de carregar os valores na visão, verifique quais os históricos padrões utilizados e a origem dos lançamentos;
2. Acesse a tela F046HPD - Cadastros / Controladoria / Contabilidade / Históricos Padrões (Cadastro de Históricos Padrões) e verifique se os históricos estão como tipo 'N' - Normal ou 'Z' - Especial para Zeramento;
2.1. Caso o histórico padrão esteja como 'Z' - Especial para Zeramento e os lançamentos possuírem origem de algum módulo (estoque, suprimentos, contas a pagar, etc.), acesse uma ferramenta de banco de dados e altere via update para 'N' o campo TipHpd na tabela E046HPD, os históricos padrões identificados.
Importante:
O sistema não permite a alteração do tipo do histórico padrão quando possui movimentações, portanto, o ajuste no histórico precisa ser realizado via banco de dados.
Atenção! Antes de realizar qualquer alteração, analise o impacto que poderá ter em outros lançamentos/processos do sistema.
Observação:
- Para mais informações sobre as Visões Contábeis no Gestão Empresarial | ERP, consulte o artigo ERP - Visões Contábeis - Onde encontrar informações sobre as visões contábeis (índice)