HCM - Transferência de filial - Histórico de crachá não pode ser alterado. Existem marcações após a data XX/XX/XXXX
Incidente
No módulo Controle de Ponto e Refeitório, ao realizar a Transferência de Empresa/Filial, é apresentada a mensagem: Histórico de crachá não pode ser alterado. Existem marcações após a data XX/XX/XXXX
Causa
Esta mensagem é apresentada, pois o colaborador já realizou marcações no dia definido para a transferência de filial (iniciou na nova empresa/filial). Portanto, o histórico de crachá não pode ser alterado devido a essas marcações existentes após a data inicial na nova empresa/filial.
Solução
Para que a mensagem "Histórico de crachá não pode ser alterado. Existem marcações após a data XX/XX/XXXX" não seja apresentada, realize os passos a seguir:
1. Realize a transferência de filial mantendo o crachá anterior do colaborador;
2. Após a finalização do processo, cadastre um novo crachá:
2.1. Cadastre o novo histórico de crachá no Controle de Ponto e Refeitório: Colaboradores / Históricos / Crachás / Titulares;
2.2. Informe como "Data Início" a data em que o colaborador iniciará as marcações neste novo crachá;
3. As marcações serão associadas ao novo crachá a partir da data informada no item 2.2, e o crachá anterior deverá estar encerrado.
Observação: Caso o colaborador já tenha marcação no dia em que está criando o histórico do novo crachá, recomenda-se que o início do novo crachá seja no dia seguinte (posterior). Assim, o dia atual não terá nenhuma inconsistência de crachás nas marcações.