ERP – Emissão – Erro ao enviar lote do estabelecimento: <CNPJ_FILIAL>. System.Net.WebException: O servidor remoto retornou um erro: (407) Autenticação de Proxy Obrigatória
Incidente
Ao emitir um documento eletrônico para a SEFAZ/Prefeitura, o mesmo fica com status Validado/Falha no Monitor e no log Sde.log é apresentado a mensagem: Erro ao enviar lote do estabelecimento: <CNPJ_FILIAL>. System.Net.WebException: O servidor remoto retornou um erro: (407) Autenticação de Proxy Obrigatória.
Causa
Esta mensagem indica que o eDocs não conseguiu efetuar conexão com o Web Service da SEFAZ/Prefeitura devido à autenticação de proxy. Esta mensagem é causada devido à problemas de parametrização do ambiente (problemas com Proxy/Firewall), não sendo um problema do eDocs.
Solução
Para tratar esse cenário, siga as orientações abaixo:
1. Verifique se o eDocs está sendo instanciado com usuário administrador da rede/domínio com acesso irrestrito aos Web Services da SEFAZ/Prefeitura (usuário dos serviços do eDocs). Para mais informações consulte o artigo ERP – eDocs Configurações – Como realizar a parametrização adequada do IIS (Internet Information Services) no servidor de instalação do eDocs;
2. Verifique se as cadeias de certificados dos WebServices da SEFAZ/Prefeitura estão instalados no servidor do eDocs.
3. Acesse a tela Configurações / Consultas URL, e verifique as URL do webservice da SEFAZ/Prefeitura que está tentando enviar o documento. Copie a URL e consulte a mesma pelo Browser.
Importante
- O acesso ao servidor (sessão) deverá ser aberta com o usuário parametrizado nos serviços do eDocs se não os testes não serão válidos. O Navegador da Web utilizado para o teste também deverá conter as mesmas informações de proxy que estão parametrizadas no eDocs;
- Os WebServices da SEFAZ poderão ser consultados no portal nacional do documento eletrônico que está sendo enviado. Os WebServices da prefeitura poderão ser verificados através do manual de integração disponibilizado pela Prefeitura.