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Incidente
No retorno de uma nota fiscal denegada o pedido vinculado está sendo reabilitado indevidamente e deveria ser cancelado automaticamente, pois não será mais faturado para esse cliente enquanto ele não regularizar a sua situação.
Causa
Este incidente ocorre, pois no retorno de uma denegação de nota fiscal não há interação com o usuário através da tela de emissão ou cancelamento de notas fiscais de saída, e por padrão, o sistema sempre efetua o retorno com a opção de reabilitar pedido selecionada
Solução
Para que o pedido não seja reabilitado é necessário criar uma regra customizada conforme os passos a seguir:
1. Utilize o identificador de regras VEN-140CANNF01 e via regra determine que quando for opção 'Cancelar Nota' a variável VSReabPed deverá ser 'N'. Para informações sobre o identificador, clique aqui para acessar a documentação completa;
1.1 Na regra utilize a operação 'Cancelar Nota' pois quando uma nota é denegada, o sistema considera como cancelada. A variável VSOperacao é Alfa e deve ser informada a operação 'Cancelar Notas' para essa situação;
1.2. Caso você precise fazer um tratamento específico para que apenas no retorno da denegação do documento a partir do eDocs o sistema não reabilite o pedido, você poderá criar uma condição na regra para baseada na variável CodUsu, onde quando a execução da regra for efetuada pelo usuário configurado no retorno do eDocs, o comportamento seja distinto de quando a operação for realizada por outros usuários em tela. Clique aqui para acessar a documentação da variável.
Importante
O usuário do retorno do eDocs pode estar atribuído no processo agendado de rotina 102 ou no próprio eDocs. Para maiores informações, clique aqui para acessar a documentação completa da integração com eDocs.
Observação