eDocs - Configuração de e-mail – O teste foi mal sucedido. Erro retornado: O servidor SMTP requer uma conexão segura ou o cliente não foi autenticado. A resposta do servidor foi: 5.5.1 Autenticação requerida
Incidente
No eDocs ao realizar a configuração do envio de e-mail e clicar no botão Testar e-mail é retornada a seguinte mensagem abaixo: O teste foi mal sucedido. Erro retornado: O servidor SMTP requer uma conexão segura ou o cliente não foi autenticado. A resposta do servidor foi: 5.5.1 Autenticação requerida.
Observação: A mensagem também pode ser apresentada em inglês, dependendo do ambiente onde o eDocs está sendo executado (O teste foi mal sucedido. Erro retornado: Authentication Required).
Causa
Essa mensagem é apresentada pois ocorreu uma falha na autenticação com o servidor de e-mail. Esta falha poderá ocorrer devido:
- Credenciais inválidas parametrizadas no eDocs;
- Bloqueio do servidor de e-mail para comunicação com aplicativos de terceiros considerados não seguros;
- Ausência da configuração do Token.
Importante
Conforme informativo disponível na Central de Suporte da Google, a partir de 14 de Março de 2025, o acesso a apps menos seguros será desativado em todas as Contas do Google, onde os protocolos CalDAV, CardDAV, IMAP, SMTP e POP deixarão de funcionar com as senhas legadas (autenticação básica), tornando-se obrigatório a utilização da autenticação pelo método OAuth2. Para mais informações, clique aqui para acessar a Central de Suporte da Google.
Solução
Para que esse incidente não ocorra, realize os passos abaixo:
1. Acesse o eDocs;
2. Entre em Configurações / Gerais e na aba E-mail;
3. Valide as credenciais informadas e as demais configurações;
4. Preencha com os dados corretos;
5. Salve as alterações;
6. Realize um teste clicando no botão Testar E-mail.
Observação:
- Em Configurações / Empresas / Envio Eletrônico, também existe a configuração do e-mail, porém o sistema só irá considerar essas informações caso o campo Customizar por Empresa esteja como Sim do contrário pega as configurações Gerais;
- Em Configurações / Filiais / Envio Eletrônico, também existe a configuração do e-mail, porém o sistema só irá considerar essas informações caso o campo Customizar por Filial esteja como Sim do contrário pega as configurações da Empresa ou Gerais;
- Para acessar o roteiro para configuração do OAuth2 - Microsoft, clique aqui;
- Para acessar o roteiro para configuração do OAuth2 - Gmail, clique aqui.
Importante:
- Para maiores informações sobre como efetuar comunicação com o servidor de e-mails utilizado e quais as parametrizações adequadas para utilização com o servidor de e-mail desejado, deverá ser acionado o responsável pelo servidor de e-mail.
- A parametrização correta dos servidores de e-mail no sistema eDocs são parametrizações de ambiente. Desta forma, caso haja necessidade de apoio na parametrização adequada do sistema, a área de serviços da Senior poderá ser acionada.