eDocs – Serviços – ORA-03113: end-of-file on communication channel Process ID: XX Session ID: XX Serial number: XX
Incidente
No Servidor, o Serviço do eDocs fica com status de Iniciado (ou Running/Executando), mas nenhum processamento é efetuado pelo mesmo. Ao verificar o arquivo de Sde.log é apresentado a seguinte informação:
Oracle.DataAccess.Client.OracleException ORA-03113: end-of-file on communication channel
Process ID: XX
Session ID: XX Serial number: XX at Oracle.DataAccess.Client.OracleException.HandleErrorHelper(Int32 errCode, OracleConnection conn, IntPtr opsErrCtx, OpoSqlValCtx* pOpoSqlValCtx, Object src, String procedure, Boolean bCheck)
at Oracle.DataAccess.Client.OracleCommand.ExecuteReader(Boolean requery, Boolean fillRequest, CommandBehavior behavior)
at Oracle.DataAccess.Client.OracleCommand.ExecuteDbDataReader(CommandBehavior behavior)
at System.Data.Common.DbCommand.System.Data.IDbCommand.ExecuteReader()
at NHibernate.AdoNet.AbstractBatcher.ExecuteReader(IDbCommand cmd)
at NHibernate.Loader.Loader.GetResultSet(IDbCommand st, Boolean autoDiscoverTypes, Boolean callable, RowSelection selection, ISessionImplementor session)
Causa
A mensagem de erro no Oracle é um erro genérico que indica que a conexão entre o processo do cliente (o aplicativo que você está usando) e o processo do servidor (o banco de dados Oracle) foi interrompida.
As causas mais comuns incluem:.
- Problemas de rede: Interrupções na rede, problemas de firewall ou um tempo limite (timeout) na conexão que encerrou a sessão;
- Problemas no servidor do banco de dados: A instância do Oracle pode ter sido encerrada inesperadamente, um processo de servidor pode ter encontrado um erro fatal, ou a máquina onde o banco de dados está rodando pode ter reiniciado;
- Recursos esgotados: O servidor do banco de dados pode ter ficado sem espaço em disco para arquivos de log, memória ou outros recursos, forçando o encerramento da conexão;
- Bugs no software Oracle: Em algumas versões específicas do Oracle, pode haver bugs conhecidos que causam esse erro em certas circunstâncias.
Solução
Para tratar este cenário, siga as orientações abaixo:
1. Acione o DBA da empresa e solicite ao mesmo para verificar a situação;
Importante:
Esta é uma questão de infraestrutura. Diante disso, caso haja necessidade de apoio para alterações em parametrizações do banco de dados, a área de Serviços da Senior poderá ser acionada para que um DBA seja alocado para verificar a questão.
Atenção! Antes de realizar qualquer alteração, analise o impacto que poderá ter em outros lançamentos/processos do sistema.