HCM – Integração Banco de Horas – Fechamento do banco de horas com anular débito 100% não zera saldo negativo
Incidente
No módulo Controle de Ponto e Refeitório, ao fazer a integração dos eventos para folha com fechamento de banco de horas anulando débito 100%, não é zerado o saldo negativo, desconsiderando a anulação de débitos.
Causa
Este incidente ocorre, pois a rotina de anular débitos (e também de abonar créditos), considera apenas lançamentos com data de compensação futuros, ou seja, após a data final do código de cálculo (período) ativo.
Solução
Para que esse incidente não ocorra, realize os passos a seguir:
- Abra ticket para o suporte solicitando proposta de customização de regra para tratar esta particularidade.
Observação
Este foi o comportamento da rotina desde a sua criação, portanto não é indicada para anular saldo negativo de lançamentos com data de compensação no período ativo. Ela foi criada pois clientes queriam que em algum momento onde por exemplo o saldo negativo fosse grande (sem ser a data de compensação), que pudessem anular algumas horas ou todas, para diminuir ou zerar o saldo.
Caso desejar podes cadastrar sugestão de melhoria no Fórum de Produtos Senior.