ERP – eDocs Envio E-mail – Erro 4.7.1 - Unable to Relay
Incidente
O envio de e-mail pelo eDocs após a autorização dos documentos não está sendo executado e no log (Sde.log) é apresentado a seguinte informação: Erro 4.7.1 - Unable to Relay.
Causa
O Relay é um processo que pode ser traduzido por encaminhamento/redirecionamento, isto é, quando um servidor é utilizado para enviar mensagens para outro domínio ou servidor.
Exemplo:
Remetente > Servidor Origem > Servidor Destino > Destinatário
joao@empresa.com.br > mail.empresa.com.br > mail.gmail.com > jose@gmail.com
O e-mail precisa ser enviado para um servidor, no exemplo do empresa.com.br, e ele envia ao outro servidor, no exemplo o gmail.com. Este processo é chamado de relay, pois o e-mail é de um cliente da empresa direcionado a um cliente de outro domínio (gmail) e o servidor precisa entregar.
O relay é proibido em duas situações:
- O destinatário do e-mail não é do servidor que está recebendo.
- Exemplo: Tentar enviar um e-mail utilizando como SMTP o empresa para um endereço do Gmail.
- Remetente / Servidor: joao@gmail.com.br / mail.empresa.com.br;
- O emissor do e-mail é do domínio e não se autenticou. Exemplo: Tentar enviar um e-mail utilizando como SMTP o Yahoo, sendo que meu e-mail é do Yahoo mas eu não passei usuário e senha para o servidor SMTP.
Solução
Para verificar essa situação, siga as orientações abaixo:
1. Verifique com o responsável pela administração do Servidor de e-mail se o mesmo requer autenticação SMTP. Caso tenha alguma duvida em como alterar o cadastro da conta de envio de e-mail no eDocs, consulte o artigo ERP – eDocs Envio E-mail – Como alterar configurações de envio de e-mails;
Observação
Caso o problema persistir, deverão ser verificadas as configurações do Servidor de e-mail, pois o Servidor de E-mail está impedindo que a mensagem seja encaminhada.