HCM – Afastamentos – Erro de acesso ao banco de dados: SQL Server 2000. Erro do banco (50000): Error Message: [Microsoft][ODBC SQL Server Driver][SQL Server]Erro de Sobreposição: - TOO MANY ROWS. Empresa: XX Tip.Col: YY Cadastro: ZZ Crachá: WW
Incidente
No módulo Controle de ponto, ao tentar incluir uma rescisão ou excluir o histórico deste afastamento, é apresentada a mensagem: Erro de acesso ao banco de dados: SQL Server 2000. Erro do banco (50000): Error Message: [Microsoft][ODBC SQL Server Driver][SQL Server]Erro de Sobreposição: - TOO MANY ROWS. Empresa: XX Tip.Col: YY Cadastro: ZZ Crachá: WW.
Causa
Este incidente ocorre, pois tem algum problema no histórico de crachá do colaborador. Pode ser tanto no crachá titular como no crachá provisório.
Solução
Para que a mensagem não seja apresentada ao efetuar a exclusão do afastamento, realize os passos a seguir:
1. Acesse o módulo de Controle de Ponto, clique em Colaboradores / Históricos / Crachás / Titulares, verifique se consta uma data final no histórico, caso não tenha coloque uma data final um dia antes da demissão;
2. Clique em Colaboradores / Históricos / Crachás / Provisórios se contem uma data final, caso não tenha adicione com a data de um dia antes da demissão;
3. Caso tenha uma data final no histórico de crachá verifique se a data não é posterior a data de demissão, caso seja ajuste para um dia antes da demissão e grave;
4. Realize o processo de zerar a apuração, no menu Diversos / Utilitários / Zerar Apuração;
5. Verifique novamente se é possível realizar a exclusão ou calcular a rescisão.
Observação
A mensagem poderá ocorrer também na mesma rotina do módulo Administração de Pessoal, ao calcular ou excluir rescisão.