Ronda XT - Harbor/BDCC - Erro na chamada do serviço. Código de retorno:11026. Retorno: CNPJ/Login/Senha fornecidos estão inválidos
Incidente
No módulo Ronda XT, ao realizar a Consulta PF é apresentado a mensagem: Erro na chamada do serviço. Código de retorno:11026. Retorno: CNPJ/Login/Senha fornecidos estão inválidos.
Logs do Harbor:
FINER [HarborLogger] (EJB default - 2) XmlModifier: Serialize doc [#document: null] to file C:\wildfly-30.0.1.Final\domain\servers\harbor\br.org.bdcc.www.BDCCModel.BDCCSinc\ANO_MES_DIA_XXXXXXXXX_CPF_XXXXX.xml (http://www.bdccmodel.bdccsinc/ANO_MES_DIA_XXXXXXXXX_CPF_XXXXX.xml) SEVERE [br.senior.seguranca.www.ws.xml.HarborSerializer] (http://www.ws.xml.harborserializer]/) (EJB default - 2) null: java.io.FileNotFoundException: C:\wildfly-30.0.1.Final\domain\servers\harbor\br.org.bdcc.www.BDCCModel.BDCCSinc\ANO_MES_DIA_XXXXXXXXX_CPF_XXXXX.xml (http://www.bdccmodel.bdccsinc/ANO_MES_DIA_XXXXXXXXX_CPF_XXXXX.xml) (The system cannot find the path specified). FINE [HarborLogger] (EJB default - 2) Código do Retorno: 11026 Descrição do Retorno: CNPJ/Login/Senha fornecidos estão inválidos FINER [HarborLogger] (EJB default - 2) Save BDCCResponse INFO [HarborLogger] (EJB default - 2) ATENÇÃO! Retorno do BDCC não contém processos. A mensagem será atualizada com status de ERRO(98) no banco sem alterar o processo enviado. Detalhes: CNPJ/Login/Senha fornecidos estão inválidos Código: 11026
Causa
Esta mensagem é apresentada, pois o sistema não consegue encontrar o caminho especificado para salvar o arquivo XML. Isso pode ocorrer devido à falta de permissão do usuário que o Harbor usa para iniciar o serviço, ou porque a pasta onde o arquivo deve ser salvo não foi criada.
Solução
Para que a mensagem não seja apresentada, realize os passos a seguir:
1. Acesse o diretório de instalação do Harbor (C:\wildfly-30.0.1.Final\domain\servers\harbor);
2. Verifique se a pasta br.org.bdcc.www.BDCCModel.BDCCSinc existe;
3. Caso não exista, crie a pasta br.org.bdcc.www.BDCCModel.BDCCSinc, conforme demonstrado abaixo;

4. Certifique-se de que o usuário que o Harbor usa para iniciar o serviço possui permissão de escrita na pasta onde o arquivo XML será salvo.