Ronda Senior XT - Integração com Hardware - Marcação de ponto não foi coletada
Incidente
No Ronda XT, ao registrar o ponto em um dispositivo registrador eletrônico de ponto (REP), a marcação não é coletada ou apresentada nas telas do sistema.
Causa
Esta situação ocorre, pois a marcação pode ter sido interrompida em diferentes etapas do fluxo de coleta, ou pode ter sido processada e classificada de forma diferente pela regra do sistema:
Falha na Coleta: A marcação pode não ter chegado à fila principal do Ronda XT (R070CMA). Isso pode ocorrer por uma falha de comunicação do driver (CSM Center, Concentradora, Driver, infra, etc.);
Pendente na Fila: A marcação está na fila (R070CMA) do coletor de marcações da CSM Center, mas aguarda o processamento. Uma fila com volume muito alto de registros antigos pode causar lentidão;
Rejeitada (Duplicidade): A marcação foi processada e movida para a tabela de rejeitadas (R070DAM), geralmente por ser um registro duplicado enviado pelo equipamento;
Desconsiderada: A marcação foi processada e movida para a tabela de não consideradas (R070MNC), geralmente porque o PIS/CPF do colaborador não foi localizado no cadastro do sistema.
Solução
Para que a marcação de ponto seja coletada e apresentada corretamente no Ronda XT, realize os passos a seguir:
Acesse o menu Acesso / Consultas / Acessos;
Realize um filtro pelo colaborador e período e confirme se as marcações de ponto (identificadas com 'Uso Marcação' = 2 e com valor na coluna 'NSR') estão presentes nesta tela;
Se as marcações forem encontradas na consulta, a coleta foi realizada com sucesso. Neste caso, acesse o sistema Gestão de Pessoas (HCM) e realize a reapuração das marcações de ponto para que sejam processadas;
Se as marcações NÃO forem encontradas na consulta (Passo 2), prossiga a verificação. Verifique se a marcação foi 'Não Considerada', o que geralmente ocorre por erro de cadastro (PIS/CPF não encontrado):
Acesse Supervisão / On-line / Marcações Desconsideradas e consulte o registro .
Verifique se a marcação foi 'Rejeitada', o que geralmente ocorre por duplicidade de registro:
Acesse Diversos / Log / Coletor e consulte o registro .
Se a marcação não for encontrada em nenhuma das telas acima, verifique se os serviços do Ronda XT e do fabricante estão iniciados corretamente no servidor de aplicação:
Senior - Serviço de informações da instalação;
Senior CSM Center Wildfly;
Senior Concentradora;
O serviço de integração do fabricante (o nome pode variar, ex: Driver SDK, Integrador, etc.).
Acesse a CSM Center Console para verificar o status da comunicação e da fila de processamento. Para mais detalhes sobre como acessar esta ferramenta, consulte o artigo: Ronda Senior XT - CSM Center - Como acessar a CSM Center Console;
Na CSM Center Console, acesse o menu Consulta Processos, localize a fila 'Coletor de Marcações' e verifique a coluna Pendentes. Um número alto pode indicar lentidão;
Importante: Se as verificações acima não identificarem a causa, solicite a um profissional com conhecimento em consultas no banco de dados (DBA) da sua empresa que realize os diagnósticos abaixo:
Verifique a quantidade de registros pendentes na fila com o seguinte comando: SELECT COUNT(1) FROM R070CMA WHERE DIRACC IN ('0', '1')
Verifique se a marcação ao menos chegou na tabela R070CMA. Se o registro não existir nesta tabela, a falha pode estar no driver do equipamento (SDK) que não consegue se conectar ao banco de dados para inserir o registro.
Caso a situação persista após todas as verificações, abra um ticket para a equipe de Suporte do Gestão de Riscos e Segurança (produto Ronda Senior). Para agilizar a análise, colete o máximo de informações e evidências, conforme as boas práticas descritas no artigo: Ronda Senior - Abertura de Ticket - Quais informações devo coletar para agilizar a análise de divergências no Ronda Senior.