Ronda Senior XT – Recursos – Bloqueio não aplicado na data configurada para o colaborador
Incidente
No módulo Recursos, ao cadastrar bloqueios para colaboradores com data futura, o bloqueio não é aplicado automaticamente na data configurada.
Causa
Este incidente ocorre, pois o sistema depende da execução do processo automático Bloqueio/Desbloqueio Colaboradores e Crachás (tipo 36) para atualizar o status do bloqueio.
Tecnicamente, a tabela que armazena os registros de bloqueio contém um ponteiro (status) que indica se o bloqueio está no passado, presente ou futuro.
Dessa forma, o processo automático é responsável por alertar o sistema de que a data do bloqueio chegou, alterando o status para ativo.
Solução
Para que o bloqueio seja aplicado corretamente na data configurada, realize os passos a seguir:
Acesse o menu Recursos / Processos Automáticos / Online;
Verifique se o processo automático tipo 36 (Bloqueio/Desbloqueio Colaboradores e Crachás) está cadastrado no ambiente;
Caso o processo não esteja cadastrado, efetue o cadastro do processo automático tipo 36;
Aguarde a execução automática do processo na data correspondente ao bloqueio configurado.