Ronda Senior XT - Totem - Delay de alguns milésimos de segundos na entrega do crachá no Totem até o envio da pendência ao dispositivo e exibição da mensagem "Erro Validade Crachá"
Incidente
Ao entregar o crachá no Totem (autoatendimento), é executada a chamada do Web Service com.hmv.g5.so.integracaoTotem.EntradaVisitante. Em seguida, o Totem realiza o tratamento das informações através do Web Service com.senior.g5.sp.visitantes.entrada.Entrada_Visitantes. Durante o registro no Totem, ao tentar registrar o dispositivo em sequência, é apresentada a mensagem Erro Validade Crachá.
Causa
Esta mensagem é apresentada, pois existem algumas configurações fundamentais para o pleno funcionamento do processo, que, se não ajustadas, podem gerar pequenos atrasos no processamento e impedir a validação correta do crachá.
Solução
Para que não seja apresentado a mensagem "Erro Validade Crachá." , realize os passos a seguir:
1. Ajuste a configuração do Middleware para pré-carregar instâncias de Web Services, evitando atrasos no processamento das requisições;
2. Limpe as tabelas R070ADM, R070ONL e R070DSP, que armazenam pendências de processamento, para reduzir o volume acumulado;
3. Ajuste o parâmetro "Excluir pendência processada com sucesso" na Central de Gerenciamento, garantindo que pendências processadas com sucesso não sejam mantidas nas tabelas;
4. Cadastre um processo automático para limpeza das pendências, mantendo o sistema otimizado.