Ronda Senior XT - HikVision - Falha no upload da imagem facial devido a problemas de decodificação
Incidente
No módulo Ronda Senior XT, ao cadastrar a facial para enviar ao equipamento, é apresentada a mensagem:
Resposta da requisição: [XXXX].MinMoe(172.022.200.091).UploadPersonFaceURL person:"IDTPES" name:"COLABORADOR" InboundJaxrsResponse{context=ClientResponse{method=PUT, uri=http://IP:PORTA/ISAPI/Intelligent/FDLib/FDSetUp?format=json, status=400, reason=Bad Request}}
{
"statusCode": X,
"statusString": "Invalid Operation",
"subStatusCode": "pictureDecodingFailed",
"errorCode": XXXXXXXXXX,
"errorMsg": "PicFeaturePoints"
}
Causa
Esta mensagem é apresentada, pois há um bloqueio na porta configurada para envio da imagem facial, impedindo que o sistema realize a comunicação com o dispositivo, ou seja, não permitindo o envio da facial para o equipamento.
Solução
Para que a mensagem não seja apresentada, realize os passos a seguir:
1. Acesse: Projeto Físico / Dispositivo / Cadastro;
2. Selecione o dispositivo;
3. Acesse a guia '6 - Informações Extensíveis';
4. Localize a propriedade 'personFace' e identifique a porta configurada.

Observação: Neste exemplo, é a porta 8888.
5. Valide o acesso à URL do Web Service de foto diretamente via navegador:
Observação: O endereço de acesso é http://IPCSM:8088/servlet/fotos/?idtpes=0100011000000001 (Exemplo colaborador Empresa 1, Tipo Colaborador 1, Número de Cadastro 1).
6. Certifique-se de que a porta identificada está desbloqueada e acessível;
7. Caso contrário, envolva a equipe de infraestrutura interno da empresa para verificar possíveis bloqueios de rede relacionados à porta (ex.: 8888) e ao IP do dispositivo.