Ronda Senior – CSM Center WildFly – Carga do Datamart não iniciada
Incidente
No módulo CSM Center Console, ao tentar subir a Concentradora, a mesma fica de forma Offline, é apresentada a mensagem: Carga do Datamart não iniciada.
E nos logs é apresentado o retorno:
WARN [org.apache.activemq.artemis.ra.ActiveMQRALogger] (default-threads - 1) AMQ153005: Unable to retrieve "EVENT_IN" from JNDI. Creating a new "jakarta.jms.Queue" named "jms.queue.EVENT_IN" to be used by the MDB.
WARN [org.apache.activemq.artemis.ra.ActiveMQRALogger] (default-threads - 3) AMQ153005: Unable to retrieve "ERROR_IN" from JNDI. Creating a new "jakarta.jms.Queue" named "jms.queue.ERROR_IN" to be used by the MDB.
WARN [org.apache.activemq.artemis.ra.ActiveMQRALogger] (default-threads - 4) AMQ153005: Unable to retrieve "KEEPALIVE_IN" from JNDI. Creating a new "jakarta.jms.Topic" named "jms.topic.KEEPALIVE_IN" to be used by the MDB.
WARN [org.apache.activemq.artemis.ra.ActiveMQRALogger] (default-threads - 2) AMQ153005: Unable to retrieve "HANDSHAKE_IN" from JNDI. Creating a new "jakarta.jms.Topic" named "jms.topic.HANDSHAKE_IN" to be used by the MDB.
Causa
Este incidente ocorreu porque o CSM Center estava tentando se conectar às filas JMS de um Profile incorreto. Ao analisar a configuração no WildFly, identificamos dois Server Groups para o CSM Center: um com servidor (e filas configuradas) e outro sem. Como os logs demonstram que as filas não estavam criadas, é possível concluir que o CSM Center estava se conectando ao Profile incorreto.
Solução
Para que a mensagem não seja apresentada, siga os passos a seguir:
1. Pare o Domínio da CSM Center;
2. Remova os Profiles, Servers Groups e Servesr utilizado na instalação Dominio;
Importante: Este processo é realizado apenas caso tenha sido criado um novo Profile durante a migração do sistema, não realizar a remoção do Profile 'full'.
3. Acesse o SeniorInstaller;
3.1 Desinstale o Dominio da CSM Center e aguarde até a finalização;
4. Acesse o SeniorInstaller;
4.1 Crie o novo Dominio da CSM Center utilizando o Profile full, segue exemplo:
5. Reinicie o Dominio da CSM Center.
Observação: É necessário avaliar e entender como está a arquitetura instalado no ambiente e seus impactos, recomendado realizar este processo fora do periodo comercial.